Poor interface to changing text color

RESOLVED DUPLICATE of bug 305867

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 305867
12 years ago
12 years ago

People

(Reporter: Ric Steinberger, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

The feature that involves chaging the color of highlighted text is very suboptimal.  It should always rememeber the last color chosen, and then display that (and not the color black) in the selection box. Then, clicking the color selection box should change the color of the selected text. This is how this feature works in Outlook, and it would be much faster if Thunderbird could do the same thing. Switching to a new color would take an extra step or two (at most), as it does in Outlook.  [Note: I am no Outlook fan.  But the way Outlook implemented this is much better than what Thunderbird has done.]

Reproducible: Always




This isn't really a bug, per se.  However it is a popular feature that should be made to work much more efficiently.  Thank you.

Comment 1

12 years ago
I second this.

The current way of selecting a different text color is just not intuitive. Shift-click helps, but for a more multi-colored message, this is still not a solution.

I agree with you that - in this rare case - the Outlook / MS Office implementation is much better:
* The toolbar button should hold the last selected color and clicking on it should change selected text to this color.
* The toolbar button should have a dropdown. Clicking on the dropdown arrow should instantly show a palet underneath the button where you can select a new color.

No ok-ing needed, no extra screen or anything, just a simple intuitive interface.


Hardware and OS should be changed from MAC to ALL as feature is requested for Windows platform too.

Using: TB version 1.5 (20051201) on Win XP

Comment 2

12 years ago
Thunderbird version of Suite bug 90670?

Comment 3

12 years ago

*** This bug has been marked as a duplicate of 305867 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.