Ugly HTML Textbox form control

VERIFIED DUPLICATE of bug 198097

Status

VERIFIED DUPLICATE of bug 198097
13 years ago
13 years ago

People

(Reporter: mozillabugs.3.maxchee, Assigned: mikepinkerton)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060203 Camino/1.0rc1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060203 Camino/1.0rc1

Camino is actually much better than Firefox when it comes to the look and feel of its HTML widgets. However, the developers might have overlooked the textbox widget, which did not adopt the Aqua look and feel.

Reproducible: Always

Steps to Reproduce:
Visit any web page with a textbox (google.com, macupdate.com etc.) and compare Camino's rendering with Safari's
The textbox on Google.com looks *exactly* the same in Safari 2.0.2 and Camino 1.0RC1.

What's the issue here?
(Reporter)

Comment 2

13 years ago
For google, Camino's rendering lacks the blue focus ring when the textbox is focused.

For macupdate, Safari's textbox has a drop down list (similar to Camino's search box), while Camino's is a plain textbox. Again, Camino's rendering lacks the blue focus ring.

Safari also displays an icon on the right of the password box when Caps Locks has been activated, while Camino's textbox lacks this feature.
(In reply to comment #2)
> For google, Camino's rendering lacks the blue focus ring when the textbox is
> focused.

That's filed, though I can't seem to find it.

> For macupdate, Safari's textbox has a drop down list (similar to Camino's
> search box), while Camino's is a plain textbox. Again, Camino's rendering lacks
> the blue focus ring.

They're using a special widget there, which is webkit only.

> Safari also displays an icon on the right of the password box when Caps Locks
> has been activated, while Camino's textbox lacks this feature.
> 

That's something that, I believe, we get with accessibility stuff (also in another bug).

I really think this bug is a WONTFIX or a dupe of one of the others.
The valid part of this bug is a dupe, so duping.

*** This bug has been marked as a duplicate of 198097 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.