bonsai mailto: highlighting is too greedy

RESOLVED FIXED

Status

Webtools Graveyard
Bonsai
RESOLVED FIXED
13 years ago
2 years ago

People

(Reporter: timeless, Assigned: timeless)

Tracking

Details

(URL)

Attachments

(1 obsolete attachment)

(Assignee)

Description

13 years ago
 
(Assignee)

Comment 1

13 years ago
Created attachment 210856 [details] [diff] [review]
only select non whitespace stuff

make it slightly less greedy
Assignee: tara → timeless
Status: NEW → ASSIGNED
Attachment #210856 - Flags: review?(LpSolit)

Comment 2

13 years ago
Comment on attachment 210856 [details] [diff] [review]
only select non whitespace stuff

>-     $text =~ s/(&lt;(.*@.*)&gt;)/<a href=\"mailto:$2\">$1<\/a>/g;
>+     $text =~ s/(&lt;(\S*@\S*)&gt;)/<a href=\"mailto:$2\">$1<\/a>/g;

r=LpSolit. But please write \S+ instead of \S* as we want at least one character before and after @.
Attachment #210856 - Flags: review?(LpSolit) → review+
(Assignee)

Comment 3

13 years ago
Comment on attachment 210856 [details] [diff] [review]
only select non whitespace stuff

mozilla/webtools/bonsai/globals.pl 	1.36
Attachment #210856 - Attachment is obsolete: true
(Assignee)

Updated

13 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 4

12 years ago
*** Bug 332816 has been marked as a duplicate of this bug. ***
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.