JavaScript commands not evaluated multiple times until input field is cleared

RESOLVED DUPLICATE of bug 238898

Status

RESOLVED DUPLICATE of bug 238898
13 years ago
2 years ago

People

(Reporter: hickeyj, Unassigned)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060206 Firefox/1.6a1

I type a command in the JavaScript Console input field and press Evaluate.  The command remains in the input field after Evalute is pressed.  If I press Evaluate again, the command is not executed.  The command cannot be re-evaluated until a different command has been executed, and the original command is re-entered.

Reproducible: Always

Steps to Reproduce:
1. Type "Hello" in the JavaScript Console input field and press Evaluate.  An error should display in the output window.
2. Press Evaluate again.  The error is not displayed a second time.
3. Clear the contents of the input field and press Evaluate.
4. Type "Hello" in the input field and press Evaluate.  A second error message displays in the output field.
Actual Results:  
After the first click of “Evaluate”, the evaluation window displayed the following:
"Error: Hello is not defined
Source File: javascript: hello" 

After the second click, a second entry did not appear in the evaluation window.  I cleared the contents of the input field and clicked “Evaluate”.  I then re-entered “Hello” and clicked “Evaluate”.  Only then did the evaluation window display another message stating:
"Error: Hello is not defined
Source File: javascript: hello"


Expected Results:  
Expected the error to display in the output window every time "Evaluate" was pressed.  Also, perhaps the text in the input field should clear after "Evaluate" is pressed.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 238898 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
(Assignee)

Updated

2 years ago
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.