Whole site doesnt work properly, looks garbled, especially the FORUM section is a mess, some of the frames are missing

VERIFIED INVALID

Status

()

Core
JavaScript Engine
P3
normal
VERIFIED INVALID
18 years ago
17 years ago

People

(Reporter: michael da kota, Assigned: rogerl (gone))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; N; Win98; en-US) Mozilla/m13
BuildID:    2000022820

Normal Netscape and IE show the site fine, but mozilla seems to mess up. Code on
the page (http://earthquake.xs4all.nl) is fine, I know that for sure, mozilla
just doesnt like it.
Try the FORUM link, thats really messed up, hope you guys can fix it!



Reproducible: Always
Steps to Reproduce:
1.browse to earthquake.xs4all.nl
2.look at your monitor
3.click on , for example, "forum"


Actual Results:  You see how messed up the page in front of you looks (cant see
much except from the topframe - there are supposed to be three frames)

Expected Results:  Shown a forum where you see the threads and posting frame as
well as the topframe.

I am no HTML guru, apologies. Talkback seems to think everything is cool so cant
help you with that either.

good luck!

Comment 1

18 years ago
-> Layout
Assignee: cbegle → troy
Component: Browser-General → Layout
QA Contact: asadotzler → petersen

Comment 2

18 years ago
Looks like the page is using LAYER related stuff which we don't support
Assignee: troy → ekrock

Comment 3

18 years ago
No, it's doing something with javascript and CSS and the DOM. The DynLayer is
coming from an external javascript file that gets sourced.

Comment 4

18 years ago
JavaScript Error: Type Error: ref.layers has no properties
URL:http://earthquake.xs4all.nl/dynlayer.js

Stranger yet, after visiting this site in Moz, all Moz windows have their menus
corrupted... File, View and Search work, but all others are toast.. they
highlight with mouse, but do not draw actual menu...

Comment 5

18 years ago
-->javascript engine
Assignee: ekrock → rogerl
Component: Layout → Javascript Engine
QA Contact: petersen → pschwartau
(Assignee)

Comment 6

18 years ago
As far as i can tell, the function DynLayerInit() is referring to 'ref.layers' 
which IS accessing document.layers, which MOZILLA don't do. I didn't see the 
menu mess up afterwards...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 7

18 years ago
Works for Me
Platform: PC
OS: Windows 98
Build # 2000100508 M18 Trunk Build
Marking as Verified

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.