Radio button marker painted too small

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: bz, Assigned: roc)

Tracking

({access, regression})

Trunk
x86
Linux
access, regression
Points:
---
Bug Flags:
blocking1.9 -
wanted1.9 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(6 attachments)

After the checkin for bug 317375, the radio button marker is painting much smaller than it should be.  It's maybe 3px across instead of 4, and not very rounded.  I'll post xmag images in a sec.
In particular, it looks like the "center" of the little dot has changed or something...  Should it be 5px instead of 4px in forms.css now?  Or should the center move back?
Vlad, dbaron, this is that bug I mentioned the other day with radio button painting.  It's pretty easy to see on this very bug page, though it's a little better in thebes builds than non-thebes ones thanks to the antialiasing thebes does on the little circle (which is ending up decidedly elliptical in thebes, but that's a separate issue).
Flags: blocking1.9a1?
Similar stuff happens with dropdown menu \/ button

Comment 6

12 years ago
Created attachment 234343 [details]
testcase

Comment 7

12 years ago
Created attachment 234347 [details]
win32 screenshot - 1024x768x96DPIx12pt default

circles and squares virtually same size as 12pt capital letter

Comment 8

12 years ago
Created attachment 234348 [details]
linux screenshot - 2048x1536x144DPIx12pt default

That marker, and the checkbox marker, have been too small for high resolution users for a long time. Comparing trunk to Epiphany 1.8.0, which is Gecko 1.7.13 here, I can't see any difference in marker size. Maybe they've grown back to where they started since this bug was filed?

I tried without success to find in forms.css why the marker is so small. Not just the marker is too small. The 13px height and width in CSS needs a relative size instead, and whatever makes the markers needs to be at least as big as Konq and Opera make them. At 1024x768x96DPI, using the 16px/12pt default, input[type="checkbox"] and input[type="radio"] at 13px come out almost the same apparent size as a capital letter. At 2048x1536x144DPI with a 24px/12pt default, the same physical font size, the boxes and circles are considerably smaller than a capital letter and the markers border on invisible. And, they are very hard to target with an arthritic mouse hand.

Maybe bug 232322 and this could be fixed with one patch?

Updated

12 years ago
Keywords: access
Felix, you're talking about a different problem -- the marker being small in general.  I'm talking about a specific regression in a specific codepath.  My problem is still there in today's builds.  Your problem should be in a separate bug.

Updated

12 years ago
Flags: blocking1.9a1? → blocking1.9-
Whiteboard: [wanted-1.9]
Flags: wanted1.9+
Whiteboard: [wanted-1.9]
This is actually WFM on trunk.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Created attachment 315456 [details]
testcase

The dot in the control is 2px by 2px of solid black, with an extra 1px-wide border of antialiased gray around that, so covers 4px by 4px overall.
Yeah, I can confirm that this looks much better than when I filed the bug.
You need to log in before you can comment on or make changes to this bug.