middlemouse.contentLoadURL is always set to true when switching OS from Windows to Linux when using the same profile

RESOLVED INVALID

Status

()

--
minor
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: bookar, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1

I have a dual-boot system with Windows and Linux installed. Both systems share the same profile stored in FAT32 Windows partition.
When I set middlemouse.contentLoadURL to false on Linux and I switch to Windows this setting remains false but when I switch back to Linux it is true again although I haven't changed it so I have to manually set it to false.

Reproducible: Always

Steps to Reproduce:
1. Have a dual-boot Windows-Linux system with a shared profile
2. On Linux set middlemouse.contentLoadURL to false
3. Switch to Windows, run firefox and set middlemouse.contentLoadURL to true
4. Switch to Linux, run firefox

Actual Results:  
middlemouse.contentLoadURL is true

Expected Results:  
middlemouse.contentLoadURL should be false
Because it's false by default in windows it will not be written to prefs.js.
So Linux will also use its default value and that's "true".
A user.js with the line user_pref("middlemouse.contentLoadURL", false);
will help in this case I assume.
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> Because it's false by default in windows it will not be written to prefs.js.
> So Linux will also use its default value and that's "true".
> A user.js with the line user_pref("middlemouse.contentLoadURL", false);
> will help in this case I assume.

Yes, you are right. The problem is in default value of this entry which is different on Linux and Windows. Firefox always deleted this entry when running on Windows so Firefox on Linux assumed default value.
The solution with user.js works great.
Thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
*** Bug 340918 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.