Closed Bug 326298 Opened 19 years ago Closed 18 years ago

Cannot paste text at start of line in HTML compose window

Categories

(Thunderbird :: Message Compose Window, defect)

Other
Linux
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 299343

People

(Reporter: doug.kramer, Assigned: mscott)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1
Build Identifier: Version 1.5 (20051201)

This is pretty simple and fundamental.  See the steps to reproduce.

Reproducible: Always

Steps to Reproduce:
1. Edit > Account Settings > Composition & Addressing > check "Compose messages in HTML format"

2. Type any text into the compose window, say "foo bar"

3. Copy text from any application (say, "bar" that you just typed) and try to paste it ahead of "foo".  This fails.  Nothing happens.

4. If you go back to step 1 and uncheck "Compose messages in HTML format", then the paste in step 3 succeeds.


Actual Results:  
After step 3, actually see:

foo bar

Expected Results:  
After step 3, should see:

barfoo bar

I searched Tbunderbird on Bugzilla and could not find this bug.
I believe it is a dupe.

Fix is checked in to Core for Firefox 1.8.0.1, so it will (I believe) be part 
of TB 1.5.0.2, and should be in nightly builds now if you care to use those.
(I was using the 1.8-branch build from Jan 29 for several weeks with no particular problems.)

*** This bug has been marked as a duplicate of 299343 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.