Closed Bug 326363 Opened 17 years ago Closed 17 years ago

Attempting to print in trunk builds shows error "An unknown error occurred while printing"

Categories

(Core :: Printing: Output, defect)

PowerPC
macOS
defect
Not set
blocker

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: nguyenhm16, Assigned: mark)

References

Details

(Keywords: smoketest)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060203 Camino/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060207 Camino/1.0+

When printing, I get the following sheet:

Printer Error

An unknown error occurred while printing

Works on 1.0rc1, 20060203 nightly

Reproducible: Always

Steps to Reproduce:
1. Go to any page
2. File->Print... or CMD-P

Actual Results:  
You get the above-mentioned error sheet

Expected Results:  
Print dialog box should come up
Just to verify...

This works fine on RC1, but *not* on the build used to file this bug?

cl
What printer do you have? Does it happen if you print to PDF? Is there any console output? Have you generated a debug log from CUPS? What color socks did you put on this morning?
Chris: Yes, this works fine on RC1, as well as the 20060203 nightly (am running it right now, hitting CMD-P brings up the print dialog as expected).

Simon: I have a Samsung ML1750. I don't even get a chance to try to print to PDF, the print dialog never shows up, just the error sheet, nothing on the console. I don't think it even gets as far as CUPS. Blue socks, as usual.

On a lark, I just tried it on the latest FireFox nightly and I get the same error:
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060207 Firefox/1.6a1

Tried the same thing on FireFox 1.5.0.1 and it works.

Looks like it's not Camino specific.
Product: Camino → Core
Summary: Can't print → Attempting to print in trunk builds shows error "An unknown error occurred while printing"
Version: unspecified → Trunk
Confirming in 0207 Firefox trunk build.  Can you try a few trunk builds and figure out when this went sour?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: mikepinkerton → printing
On FireFox, it worked with this build:
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060204 Firefox/1.6a1

But stopped working with this build:
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060205 Firefox/1.6a1
Probably caused by bug 324072.
Blocks: 324072
We don't save per-printer settings on the Mac.
Assignee: printing → mark
Status: NEW → ASSIGNED
Attachment #211145 - Flags: superreview?(roc)
Attachment #211145 - Flags: review?
Attachment #211145 - Flags: review? → review?(kherron+mozilla)
Attachment #211145 - Flags: superreview?(roc) → superreview+
Comment on attachment 211145 [details] [diff] [review]
Don't call GetDefaultPrinterName on Mac

Just to be clear, The old code (before bug 324072) would have initialized retval with the name of the last printer used. The old code will not do that because the code to load that information was removed from |InitPrintSettingsFromPrefs|. Assuming that's okay, this patch looks fine.
Attachment #211145 - Flags: review?(kherron+mozilla) → review+
I see.  Functionally, this seems fine, but I'll take another look to clean up the assertions.
*** Bug 327028 has been marked as a duplicate of this bug. ***
Severity: major → blocker
Keywords: smoketest
I'm probably going to back out the patch for bug 324072 and write a slightly different patch that can be accepted on the 1.8 branch. I'd like to avoid breaking  printing on MacOSX with the new patch, but I don't understand exactly what's wrong with the current code. Mark, could you explain more specifically how the current code (including the patch for bug 324072) is failing?
We don't deal with named printers on the Mac, we only send things to "the printer."  No per-printer prefs are ever saved.  We have no printer enumerator, and GetDefaultPrinterName always fails.
*** Bug 327492 has been marked as a duplicate of this bug. ***
Kenneth, what's the story here?  I don't want to leave this broken for too much longer, so if your revised solution to bug 324072 is going to take a while, I'll revise the patch on this bug to at least provisionally get trunk printing working again on the Mac.
Blocks: 324141
The patch from bug 324072 is backed out. Could someone retest this and resolve the bug if it's fixed?
(In reply to comment #15)
> The patch from bug 324072 is backed out. Could someone retest this and resolve
> the bug if it's fixed?
> 

In tinderbox-build, This problem is solved.
Mac OS X 10.3.9
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060304 Firefox/1.6a1
This is better now on the trunk after the backout of bug 324072.  Thanks, Kenneth.

Clearing bogus dependency.
No longer blocks: 324141
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → WORKSFORME
In Camino, it still reproduces...

Mac OS X 10.3.9
Camino which built from source of trunk.
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; ja-JP; rv:1.9a1) Gecko/20060305 Camino/1.2+
(In reply to comment #18)
> In Camino, it still reproduces...

The one camino-specific change was backed out with the rest of it. I don't have a Mac build environment so unfortunately I can't troubleshoot this.
This bug is fixed.  Camino (and other Cocoa widget-based products) still won't print due to bug 329455.
You need to log in before you can comment on or make changes to this bug.