Add feature to Reload toolbar to auto-reload page after X minutes.

RESOLVED DUPLICATE of bug 278098

Status

()

RESOLVED DUPLICATE of bug 278098
13 years ago
12 years ago

People

(Reporter: matthew.w.workman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

Add a pulldown to the "Reload current page" toolbar icon (like the pulldown on the Back and Forward icons) that shows a list of a few auto-reload frequencies.

When the user chooses one of these, it is checked and the page auto-reloads itself at that choosen frequency.

For example, the user goes to yahoo.com and clicks on the Reload pulldown, a list is shown:
  1 minute
  5 minutes
  30 minutes
  1 hour
  24 hours

The user clicks on '5 minutes'.  Now that page is auto-reloaded (as if the user clicked the reload button themselves) every 5 minutes.

The '5 minutes' option would be checked, so they can see what they choose.  The user can change it to some other frequency.

You could even save the auto-reload settings per page in some dB.  So, later visits to the site have the same auto-reload frequencies.  

Also, ideally, the page would reload and position itself automatically to the same position on the page it was originally at.  Ie: if the user is 50% down the page when the reload occurs, the reload will happen and the screen will display from the 50% point downward.  

Reproducible: Always
There's an extension and a bookmarklet with this function.
http://subsimple.com/bookmarklets/collection_navigation.asp

Comment 2

13 years ago
See bug 278098.
(Reporter)

Comment 3

13 years ago
I was really wanting this to be an integral part of the browser, not an add-on.

People don't have to add-on 'back' and 'forward', why do they have to add this on?
I think because the Back and Forward buttons are elementary but not this continuous reload function. 

Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 278098
You need to log in before you can comment on or make changes to this bug.