Closed Bug 326440 Opened 16 years ago Closed 15 years ago

scroll bar of div section appears even though other div section is covering it

Categories

(Core :: Layout, defect)

1.8 Branch
PowerPC
Windows XP
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 187435

People

(Reporter: fadi, Unassigned)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Macintosh;U;PPC Mac OS X Mach-O; en-US; rv:19.a1) Gecko/20060208 Firefox/1.6a1

2 tables inside div tags are setup so that lower table over-laps the upper table and covers the upper div's scroll bars (scroll bars are kept in sync using javascript). This works fine on PC platforms. The scroll bar that is covered by the lower table reamins covered. On Mac, using 1.0, the scoll bars appears when the user starts scrolling and then disappears when user is no longer scrolling. Using 1.5 or 1.6a1, the scroll bar always appears. This same problem appears in Netscape 7.1 but works correctly in netscape 7.2 (on Mac), so problem seems specific to firefox.

Reproducible: Always

Steps to Reproduce:
1. Attached is a sample html file
2. Pull up the page in a firefox on Mac and scroll to see the problem



Actual Results:  
On PC work fine using firefox, netscape and IE. 
On Mac, 
1. using firefox scroll bars appears.
2. Using Netscape 7.1, scroll bars appear.
3. Using Netscape 7.2, works fine

Expected Results:  
Scroll bar of upper div should be hidden (covered) by lower div
Attached file sample htm code
Attached image screen shot of problem
I'm not sure if this is the same bug, but it looks similar to what I read here. Try this URL: <http://brainjar.com/dhtml/windows/demo.html>. I always see the scroll bars (I'm using Firefox 1.5.0.1 on OS X) and they seem to overlap the content of the CSS "windows".
Yes, I just tried  <http://brainjar.com/dhtml/windows/demo.html> and it looks like the same problem. Works fine in windows, works fine in NS72 on MAC, but does not work in firefox 1.5 on MAC. The scroll bars still appear even though the div is covering them.
I also ran into this bug. I could reproduce it with the attached sample HTML code, in Firefox 1.5.0.4 as well as Camino 1.0.1 on Mac OS X 10.3.9.
I don't see this under windows neither using a 1.8 branch build, nor on trunk. Mac-only?
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → 1.8 Branch

*** This bug has been marked as a duplicate of 187435 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.