Closed Bug 32645 Opened 20 years ago Closed 20 years ago

Cache Dir - Profile Manager

Categories

(Core Graveyard :: Profile: Migration, enhancement, P3)

enhancement

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 19184

People

(Reporter: netdragon, Assigned: dbragg)

Details

I know you want Mozilla to be fast, but files in the cache dir should really be 
128 bit encoded. The reason is that children could have access to adult content 
that was viewed earlier by a parent. Maybe there is a way that you could make 
doing so fast.
Cookie files should be encoded and the titles should not contain the name of 
the site because they might have objectionable material in them.
Also the history is a problem, because it could contain names of sites with 
objectionable words. Maybe the software could recognize those kind of words and 
password protect such history entries.
Maybe you could do this through profiles. Each profiles has its cache and any 
other sensitive information encrypted.
If adults are viewing adult content on machines accessible to kids, they deserve 
everything they get :-)

The best thing is to delete the history and the cache. There are "Clear Memory 
Cache" and "Clear Disk Cache" buttons in the preferences, if you want to do it 
manually, or you can get small "privacy" programs that do this for you.

Seeing as there's no "Cache" component, I'm moving this to Cookies for them to 
evaluate the cookie part of the enhancement.

Gerv
Assignee: cbegle → morse
Severity: normal → enhancement
Component: Browser-General → Cookies
QA Contact: asadotzler → tever
This will involve a lot of migration code to handle currently existing files 
that are not encrypted.  Changing component to profile migration.
Assignee: morse → dbragg
Component: Cookies → Profile Migration
QA Contact: tever → gbush
Duplicate in 19184 - a bug I posted a while ago and forgot about :)
It was assigned to leger@netscape.com

*** This bug has been marked as a duplicate of 19184 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Target Milestone: --- → M20
Sorry, I mean don. Sheesh :)
ok
Status: RESOLVED → VERIFIED
Clearing the cache unfortunately erases all the good sites too. This should be 
for profile. If the profiles have everything cached and were password protected 
and encrypted then it would keep prying eyes away from everything including 
email. Especially from people who know a little about computers
Summary: Cache Dir → Cache Dir - Profile Manager
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.