mozilla sends double requests to server on empty src tag

RESOLVED DUPLICATE of bug 263239

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 263239
12 years ago
12 years ago

People

(Reporter: Rotem Tamir, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

hi,
my name is Rotem Tamir and I'm a php developer.  I've recently had a very serious problem in one of the applications I'm developing -- when I finally tracked it down it was in the way Mozilla (1.5) was processing my (badly written) html code. I had the following line in my header:
<link rel="shortcut icon"  href="">
this line caused php scripts to be loaded twice and cause me quite a headache.  IE processes this fine.  I think a browser as good as mozilla can do the same.

Thanks for your attention,
Rotem Tamir

Reproducible: Always

Steps to Reproduce:
1. <link rel="shortcut icon"  href=""> in the <head> tag
2.
3.

Actual Results:  
sends duplicate requests to the php scripts (including all the variables in the form)

Expected Results:  
form on the php script is sent twice to the script and double INSERTs occur in the SQL DB.

ignore the src="" instead of requesting the same page again.
As you say, you have written bad html. You are telling the browser that the page has a shortcut icon at url "" which is taken to be the same url as the current page, so the browser attempts to load the shortcut icon from there.

This is what the browser should be doing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

12 years ago
well, i've seen this happen to a few developers around the web.. IE processes this fine.  I think mozilla should as well.

Rotem
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 3

12 years ago

*** This bug has been marked as a duplicate of 263239 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.