Issue with the style display:table-cell when it contains a script tag with the src attribute

RESOLVED DUPLICATE of bug 121142

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 121142
13 years ago
13 years ago

People

(Reporter: Xavier OTTOLINI, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

I created a page with 3 div having the CSS style display to table cell. If it
contains a script tag with the src attribut, the third cell is dispaly below the others.

Reproducible: Always

Steps to Reproduce:
1.create 3 divs with the style display to table
2.create 3 divs with the style display to table-cell
3.create a select with at least one option

Actual Results:  
The third column is below the others

Expected Results:  
The third column should be on the same row as the 2 previous rows, on the right
side.

<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<title>test script</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<style type="text/css">
.table {
display:table;
width:100%;
}


.cell1, .cell2, .cell3  {
display:table-cell;
}

.cell1 {
background-color:#00FFFF;
}
.cell2 {
background-color:#FF00FF;
}
.cell3 {
background-color:#FFFF00;
}
</style>
</head>

<body>
<div class="table">

<div class="cell1">&nbsp;</div>
<div class="cell2"><script type="text/javascript" src="../a-script.js"></script>&nbsp;</div>
<div class="cell3">&nbsp;</div>

</div>
</body>
</html>

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 121142 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.