WMP: while loading, content is displayed on top of all

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
13 years ago
3 years ago

People

(Reporter: hhschwab, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20060207 SeaMonkey/1.5a

WFM: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20060207 Firefox/1.6a1

If I load the URL above, Windows Media Player starts. I'm on ISDN, so loading max. 8 kbyte/sec, that takes some time. After some time, content is seen, but still loading. If I start the movie, and then switch tabs, the content is still on top of windows. This behaviour lasts as long as the content is loading, all is ok after content has loaded. I can reproduce it using Shift-Reload to start a new loading cycle, and then switching tabs again.

If I start the movie while not completely loaded and switch tabs or browser, it stays on top, even above win98 context menu.
If I start the movie after it has completely loaded and switch tabs, all is normal.

Windows is win98 Standard Edition, WMP is 6.4.07.1112
(Reporter)

Comment 1

13 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20050830 SeaMonkey/1.1a

simpler steps to repeat:
1. Load URL
2. try to start movie while loading
3, when movie has started, scroll up and down, and see movie jumpimg

HTTP header:
----------------------------------------------------------
http://www.thehumorarchives.com/attachment.do?attachmentId=400&ts=1139504222568&s=F657F646AB9FC44B540C7A8624F106929425AB7B

GET /attachment.do?attachmentId=400&ts=1139504222568&s=F657F646AB9FC44B540C7A8624F106929425AB7B HTTP/1.1
Host: www.thehumorarchives.com
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20060120 SeaMonkey/1.5a
Accept: text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
Accept-Language: en-us,en;q=0.8,fr;q=0.6,de;q=0.4,es;q=0.2
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive
Cookie: JSESSIONID=59FAEBEC3FEB4E120CDCC8CEFE649730

HTTP/1.x 200 OK
Date: Thu, 09 Feb 2006 16:57:16 GMT
Server: Apache/1.3.33 (Unix) mod_jk/1.2.6 PHP/5.0.5 mod_gzip/1.3.26.1a
Vary: *
content-disposition: inline; filename=Comedy_-_Cat_Fight.mpg
Content-Length: 1474560
Keep-Alive: timeout=15, max=95
Connection: Keep-Alive
Content-Type: video/mpeg
----------------------------------------------------------

Comment 2

13 years ago
Might it be Firefox uses a newer WMP player version than SeaMonkey (if there is one for Win98)?
(Reporter)

Comment 3

13 years ago
(In reply to comment #2)
> Might it be Firefox uses a newer WMP player version than SeaMonkey (if there is
> one for Win98)?

no, it is the same computer, Firefox and Seamonkey can run sametime.

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.0.1) Gecko/20060130 SeaMonkey/1.0

Steps to repeat:
1. load http://www.thehumorarchives.com/humor/0001291.html
2. while loading, scroll up + down
3. after loading scroll up + down

When content starts to load, content leaves its window, when scrolling, and can stay outside the small WMP content window.
After content has loaded, content also jmps on scrolling, but always gets back into its confinement.
Maybe that also depends on the slow celeron 333MHz CPU I'm running.
(Reporter)

Comment 4

13 years ago
same behaviour on Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4.2) Gecko/20040426

Comment 5

13 years ago
It's just on PCs with a newer WMP SeaMonkey runs 6.4 and Firefox runs version 9 or 10 (since they included some code SeaMonkey does not have).
(Reporter)

Comment 6

13 years ago
(In reply to comment #5)
> It's just on PCs with a newer WMP SeaMonkey runs 6.4 and Firefox runs version 9
> or 10 (since they included some code SeaMonkey does not have).

That's Bug 193883
WMP9 Plugin installed, but 6.4 is used. Add exe names seamonkey.exe/mozilla.exe to ShimInclusionList

But I'm running the same WMP 6.4 on Seamonkey and Firefox, it's the same system.

seen on 
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20060207 Firefox/1.6a1

WFM
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

These three tested with different profiles on this computer while writing here.
Test done was scrolling while loading.
OS: Other → Windows 98
(Reporter)

Comment 7

13 years ago
confirming: 
Bug seen in Mozilla 1.4, Seamonkey 1.0, Seamonkey trunk, Firefox 1.0.7, Firefox trunk. I've heard bug was seen in Win2k.

wfm: Firefox 1.5.0.1 on the same system the others show the bug.

simple steps to repeat: scroll while content is loading
http://www.thehumorarchives.com/humor/0001291.html
Assignee: general → nobody
Status: UNCONFIRMED → NEW
Component: General → Plug-ins
Ever confirmed: true
Product: Mozilla Application Suite → Core
QA Contact: general → plugins

Updated

9 years ago
Component: Plug-ins → Windows Media Player (Microsoft)
Product: Core → Plugins
QA Contact: plugins → microsoft-wmp
Version: Trunk → unspecified

Comment 8

3 years ago
Closing old bugs in the Plugins component. We aren't going to track issues in 3rd-party plugins in the Mozilla bug tracker. In addition, support for NPAPI plugins will be removed at the end of this year; for more details see the post at https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/

If there is a serious bug in Firefox, it needs to be filed in the "Core" product, "Plug-Ins" component.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INCOMPLETE
(Assignee)

Updated

3 years ago
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.