Closed Bug 326557 Opened 17 years ago Closed 17 years ago

assert in prtime.c:1558 while getting mail headers from imap server

Categories

(Thunderbird :: General, defect)

x86
Linux
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 247896

People

(Reporter: sxpert, Assigned: mscott)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.1) Gecko/20060206 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.1) Gecko/20060206 Firefox/1.5.0.1

somehow a mail must have a malformed date string or somethign (I don't have enough info to inverstigate which mail, unfortunately, and I end up in an assert

Assertion failure: tm.tm_month > -1 && tm.tm_mday > 0 && tm.tm_hour > -1 && tm.tm_min > -1 && tm.tm_sec > -1, at ../../../../mozilla/nsprpub/pr/src/misc/prtime.c:1558

Program received signal SIGABRT, Aborted.
[Switching to Thread 46912551144800 (LWP 29613)]
0x00002aaaacb2c329 in raise () from /lib/libc.so.6
(gdb) bt
#0  0x00002aaaacb2c329 in raise () from /lib/libc.so.6
#1  0x00002aaaacb2d4ec in abort () from /lib/libc.so.6
#2  0x00002aaaac233242 in PR_Assert () from /usr/lib64/nspr/libnspr4.so
#3  0x00002aaaac243ba8 in PR_ParseTimeString () from /usr/lib64/nspr/libnspr4.so
#4  0x00002aaab2a8ba73 in nsParseMailMessageState::FinalizeHeaders () from /usr/lib64/mozilla-thunderbird/components/libmail.so
#5  0x00002aaab2a8a0b5 in nsParseMailMessageState::ParseFolderLine () from /usr/lib64/mozilla-thunderbird/components/libmail.so
#6  0x00002aaab2a8a037 in nsParseMailMessageState::Init () from /usr/lib64/mozilla-thunderbird/components/libmail.so
#7  0x00002aaab2b48fb7 in nsImapMailFolder::ParseAdoptedHeaderLine () from /usr/lib64/mozilla-thunderbird/components/libmail.so
#8  0x00002aaab2b48dbb in nsImapMailFolder::GetBodysToDownload () from /usr/lib64/mozilla-thunderbird/components/libmail.so
#9  0x00002aaaabeb5090 in XPTC_InvokeByIndex () from /usr/lib64/mozilla/libxpcom.so
#10 0x00002aaaabe9af2a in nsProxyObject::Post () from /usr/lib64/mozilla/libxpcom.so
#11 0x00002aaaabe91ced in PL_HandleEvent () from /usr/lib64/mozilla/libxpcom.so
#12 0x00002aaaabe91c03 in PL_ProcessPendingEvents () from /usr/lib64/mozilla/libxpcom.so
#13 0x00002aaaabe941cf in nsEventQueueImpl::NotifyObservers () from /usr/lib64/mozilla/libxpcom.so
#14 0x00002aaaaf35cbde in nsBaseWidget::FreeNativeData () from /usr/lib64/mozilla-thunderbird/components/libwidget_gtk2.so
#15 0x00002aaaabc4452d in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#16 0x00002aaaabc45e6b in g_main_context_acquire () from /usr/lib/libglib-2.0.so.0
#17 0x00002aaaabc461b3 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#18 0x00002aaaaaea2c6b in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#19 0x00002aaaaf35d096 in nsAppShell::ReleaseGlobals () from /usr/lib64/mozilla-thunderbird/components/libwidget_gtk2.so
#20 0x00002aaaae92eed0 in nsAppShellService::AttemptingQuit () from /usr/lib64/mozilla-thunderbird/components/libnsappshell.so
#21 0x000000000040df77 in ?? ()
#22 0x00000000004090e8 in ?? ()
#23 0x00002aaaacb1a646 in __libc_start_main () from /lib/libc.so.6
#24 0x000000000040904a in ?? ()
#25 0x00007ffffff636a8 in ?? ()
#26 0x000000000000001c in ?? ()
#27 0x0000000000000001 in ?? ()
#28 0x00007ffffff646a4 in ?? ()
#29 0x0000000000000000 in ?? ()


Reproducible: Always

*** This bug has been marked as a duplicate of 247896 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.