counter-reset property don't work inside :before element

RESOLVED DUPLICATE of bug 288946

Status

()

--
minor
RESOLVED DUPLICATE of bug 288946
13 years ago
13 years ago

People

(Reporter: edoardo, Assigned: dbaron)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; it; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; it; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

The H2 elements must have consecutive numbers before the text.
But if the counter-reset is inside H1:before this don't works.


Reproducible: Always

Steps to Reproduce:
1.load the page
2.
3.

Actual Results:  
The value of the counter ("section" in the example page) is always 1

Expected Results:  
an incremented counter before H2 elements

The page "http://elrond.aspix.it/generated.html" works correctly with Opera and also with FireFox if I put counter-reset in a separate H1 element, as in 
---------------------------------------------
H1:before {
  content: counter(chapter) ". ";
  counter-increment: chapter; 
}
H1 { counter-reset: section; }
---------------------------------------------
it works

I can't figure if this is a required behaviour.
Duplicate of invalid bug.

*** This bug has been marked as a duplicate of 288946 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.