button element changes size when disabled

RESOLVED WORKSFORME

Status

()

Firefox
General
--
trivial
RESOLVED WORKSFORME
13 years ago
8 years ago

People

(Reporter: Juan Lanus, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

A button is higher after being disabled via JavaScript. This produces an annoying displacement of the content below. 
See picture: it's the same button element enlarged with several control+, left half is normal, right half is when disabled.
It appears as if the grayed text were bigger than the same text in black. 

The source in two versions, normal and disabled:
<button type="button" id="continuar" value="overlayAvance" class="overlayAvance" tabindex="211" accesskey="+" title="avanzar al paso siguiente alt+" onclick="javascript: verOverlay('deducciones'); return false;">continuar</button>

<button disabled="disabled" type="button" id="continuar" value="overlayAvance" class="overlayAvance" tabindex="211" accesskey="+" title="avanzar al paso siguiente alt+" onclick="javascript: verOverlay('deducciones'); return false;">continuar</button>

The CSS: 
	.overlayBotones {
		text-align: center;
	}
	.overlayAvance {
		border: 4px solid teal;
		background-image: url("imag/butContinuar.gif");
		background-repeat: no-repeat;
		background-position: right center;
		background-color: white;
		margin-left: 0em;
		margin-top: 8px;
		padding-right: 2em;
		vertical-align: middle;
		font-weight: 700;
		-moz-border-radius: 9px;
	}

Reproducible: Always

Steps to Reproduce:
1.http://tecnosol.com.ar/ig4c/01.html (is a prototype, might disappear)
2.click the button to gen to the following overlay
3.enter a letter in a field and tab to provoke a blur: this disables the bottom buttons and makes them grow a little bit




I'm attaching a picture of the button greatly enlarged, taken before and after the growth.
(Reporter)

Comment 1

13 years ago
Created attachment 211331 [details]
enabled and disabled button halves side by side
(Reporter)

Comment 2

13 years ago
I've set a copy of my page I won't change to be used as the test case:

New steps to Reproduce (can´t I change the original?):
1. http://tecnosol.com.ar/fftestcase/01.html
2. click the button to gen to the following overlay
3. enter a letter in a field and tab to provoke a blur: this disables the bottom buttons and makes them grow a little bit
(Reporter)

Comment 3

13 years ago
This might be a related problem:
1- open http://www.mymusictools.com/plug-ins_14/index.htm with Firefox
2- scroll to the bottom of the page and find the page advancing "1  2  3  >>"
3- click the ">>" near it's top
3- The page content moves a bit down and the link doesn't fire because the mouse-up happens outside the link area (only when clicking near the top)
4- it does not happen in Mozilla 1.7.12

Updated

11 years ago
Version: unspecified → 1.5.0.x Branch
This bug was reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.3 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
(Reporter)

Comment 5

8 years ago
It does not show in ff3.6.3
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Not FIXED, there was no patch checked into the tree. If you don't see it anymore, WFM
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.