Stack trace of a tbird UI hang

RESOLVED INVALID

Status

Thunderbird
General
--
critical
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Aleks Totic, Assigned: Scott MacGregor)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

This is one of those that are irreproducible and happen every once in a while. I was running a home-build debug thunderbird, with venkman. The UI froze, and I attached the debugger, and I'll attach the stack trace. Looks like some JavaScript GC thingy. 

Reproducible: Sometimes
(Reporter)

Comment 1

12 years ago
Created attachment 211361 [details]
stack trace

Updated

12 years ago
Keywords: hang
(Reporter)

Comment 2

12 years ago
Funny thing was, after debugger disconnected from Tbird, the UI was no longer hung. Very strange. I know that when connecting the hung was real, because MSVC reported "The application you are connecting to is not responding".

Comment 3

12 years ago
Alex

is this gone in version 1.5.0.4?  http://www.mozilla.com/thunderbird/releases/1.5.0.4.html

if it still happens test a trunk build where it may be fixed. http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-trunk/

Please report results in this bug. Also, please set the version information.

other hang bugs - Bug 324196, Bug 324325, Bug 340647
Severity: normal → critical
(Reporter)

Comment 4

12 years ago
I have a feeling that this was due to my specific setup at the time.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.