bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

node.setUserData("foo", anyNode, null) leaks GC roots and DOMWindows

RESOLVED DUPLICATE of bug 324871

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 324871
13 years ago
12 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

({memory-leak, testcase})

Trunk
PowerPC
Mac OS X
memory-leak, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
JS engine warning: leaking GC root 'XPCVariant::mJSVal' at 0x2459f294
JS engine warning: 1 GC root remains after destroying the JSRuntime.
                   This root may point to freed memory. Objects reachable
                   through it have not been finalized.
(Reporter)

Comment 1

13 years ago
Created attachment 211365 [details]
testcase
(Reporter)

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 324871 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
No longer depends on: 324871
Resolution: --- → DUPLICATE
(Reporter)

Updated

13 years ago
No longer blocks: 326633
So I actually don't immediately see why the document is being kept alive in this case, although I suspect from the warning that fixing this requires treating XPCVariant like bug 241518 treated nsXPCWrappedJS -- by marking rather than rooting.
This appears to be a bug that was created since the 1.8 branch, since bug 326635 landed after the branch; therefore maybe it can wait for graydon's cycle collector to fix the problem.
You need to log in before you can comment on or make changes to this bug.