Closed Bug 326698 Opened 14 years ago Closed 14 years ago

Safari saved passwords and usernames not imported

Categories

(Firefox :: Migration, enhancement)

PowerPC
macOS
enhancement
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: pamg.bugs, Unassigned)

References

(Depends on 1 open bug)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20060131 Firefox/1.5

Usernames and passwords saved in Safari were not imported.

Reproducible: Always

Steps to Reproduce:
1. Launch Safari
2. Open Safari Preferences
2. Make sure "User names and Passwords" is enabled in AutoFill tab
3. In Safari, browse to a site with a password, e.g. www.amazon.com, and log in
4. Click "Yes" when Safari asks to remember the password
5. Quit Safari
6. Launch Firefox
7. Choose File:Import... and import data from Safari
8. Browse to the same password-protected site visited in Safari

Actual Results:  
Username and password are not entered by Firefox.  They are also not listed in the  Passwords tab of the Privacy pane of the Firefox Preferences.

Expected Results:  
Username and password would be imported from Safari and stored with other saved passwords.

This is the 20060131 Places build, posted as the 20060128 nightly.
Component: Places → Migration
Really, the Right Thing(tm) on OS X is to use the Keychain directly, instead of importing some/all of the passwords into a separate password manager.  There's a bug on doing exactly that, in fact.

WONTFIX since this is really the wrong answer.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.