left clicks/drags in URL bar ignored after right click in URL bar

VERIFIED FIXED in M17

Status

()

Core
Editor
P3
minor
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: ex_cyber, Assigned: kinmoz)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; N; Win98; en-US; m14)
BuildID:    2000032105

After right-clicking on the URL bar, any further click/drag with the left mouse
button has no effect.

Reproducible: Always
Steps to Reproduce:
1. Right-click on the URL bar.
2. Left-click on the URL bar.
3. Attempt to reposition the cursor or select text by left-clicking/dragging in
the URL bar.


Actual Results:  The cursor disappears, and cannot be repositioned by clicking.
Text can also not be selected by dragging. Keyboard input still works, with the
actual position of the cursor being the last visible cursor position. Selection,
cursor movement, copy and paste work with the keyboard, although the cursor and
any highlighting are invisible. After clicking on the page area, URL bar
behavior returns to normal. Clicking on other browser widgets does not return
URL bar behavior to normal.

Expected Results:  Left-clicking should reposition the cursor. Left-dragging
should select text. I have no idea what right clicking should do, but I don't
think it should do what it does.

Comment 1

18 years ago
reproduced using 32809 verification build on Win98SE. Same thing happens in form
textfields and textareas.  Clicking in any other textfield clears the problem.
changing component to editor, reassigning.
Assignee: trudelle → brade
Component: XP Toolkit/Widgets → Editor
QA Contact: jrgm → sujay

Comment 2

18 years ago
assigning to kin and setting to M17
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → M17

Comment 3

18 years ago
assigning to kin
Assignee: brade → kin
(Assignee)

Comment 4

18 years ago
Accepting bug.
Status: NEW → ASSIGNED

Comment 5

18 years ago
this is now fixed using a current version
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 6

18 years ago
verified in 9/12 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.