bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

Bookmarks Toolbar slow to appear at launch

RESOLVED FIXED in Firefox 2 alpha2



Bookmarks & History
12 years ago
8 years ago


(Reporter: Pam Greene, Assigned: Brett Wilson)


Firefox 2 alpha2
Mac OS X

Firefox Tracking Flags

(Not tracked)




12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv: Gecko/20060111 Firefox/
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20060131 Firefox/1.5

At times, the bookmarks in the main Bookmarks Toolbar take roughly 10 seconds to appear after the window seems to have fully loaded at launch.  "Show Places" apepars in the corner, but no bookmarks or bookmark folders appear, and clicking where they would appear has no effect.

Once the bookmarks have appeared, behavior is normal for the remainder of the session.

This problem is intermittent.  I have not been able to determine exactly what circumstances cause it, but it appears to be more common after importing data (in particular, I'm importing Safari's default bookmarks).  One launch may show the problem when the previous and succeeding launches don't.  On average it seems to happen once every 2 to 4 launches, once it's started happening at all.

Reproducible: Sometimes

Steps to Reproduce:
1. Optional: Create a new Firefox profile, then import data from Safari
2. Launch Firefox
3. Watch Bookmarks Toolbar

Actual Results:  
Bookmarks don't appear until roughly 10 seconds have passed.

Expected Results:  
Bookmarks should appear more or less immediately.

This is the 20060131 Places build, posted as the 20060128 nightly.
I think this is related to the livemark notification lockup. The bookmarks are loaded after the window is shown. If the livemarks are updated before the folder is loaded, this effect will occur. Dup or dependency of that bug. 
Assignee: nobody → brettw
Ever confirmed: true
Priority: -- → P2
Target Milestone: --- → Firefox 2 alpha2
I think this has since been fixed. 
Last Resolved: 12 years ago
Resolution: --- → FIXED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.