Some history data is not properly searched

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
13 years ago
10 years ago

People

(Reporter: mccpat, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

When you visit http://cpumag.com/idealbb, a history entry will be added, named "idealbb". Open up the history bar, you will see it there. However, typing "idealbb", or anything in the word "idealbb", it will not show up, even if it is in the visited pages history.

Reproducible: Always

Steps to Reproduce:
1. Go to http://cpumag.com/idealbb
2. Notice "idealbb" entry in visted pages history
3. Type "idealbb", or anything in the word "idealbb" in the history searcher; the entry will not show
(Reporter)

Comment 1

13 years ago
EDIT: I seem to have found the reason for this problem. Notice when you type "http://cpumag.com/idealbb", the website URL changes. This is because it redirects to the actual website, and FF adds "idealbb" to the visted pages history after the redirection, along with the actual website's history entry. Copy and paste the URL  in the address bar after the redirection (it should be one with a bunch of random data appended to it), and hit enter to go to it. Notice you don't get the "idealbb" entry when the site loads. But when you type "http://cpumag.com/idealbb", the "idealbb" entry shows up, along with the site entry. Too bad I don't know C++, I'd try to fix this myself. Might as well try anyway. :)

Comment 2

13 years ago
This is probably due to the fact that History search only searches page titles and not URLs -- a problem.

Comment 3

13 years ago
This is already fixed in Firefox 3 where we search URLs as well. There is no possibility anything related to history searching will get fixed for Firefox 2. It would be great if want to try the lastest trunk builds and see if the searching does what you want. File history search bugs on trunk under the "places" component.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX

Updated

10 years ago
Component: History → Bookmarks & History
QA Contact: history → bookmarks
You need to log in before you can comment on or make changes to this bug.