Clicking on list bullet/marker no longer selects item

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: aguertin+bugzilla, Assigned: roc)

Tracking

({regression})

Trunk
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

Reporter

Description

14 years ago
Previously, clicking on the bullet/marker for a list item would select the item. In recent builds, this has regressed. 

I haven't checked the regression range, but it's probably recent.
Which build are you using? 02-10 trunk? Please always give build IDs in bug reports.
Reporter

Comment 2

13 years ago
Sorry, yes, I believe that was the build. In any case, it's still a problem with 02-19 trunk.
Reporter

Comment 3

13 years ago
This is only a problem for <li>s that are actually in a <ul>. ie.

data:text/html,<li>text

does not have this problem, but

data:text/html,<ul><li>text</ul>

does.

Comment 4

13 years ago
Still see the problem?  can you create a test case and attach?
Reporter

Comment 5

13 years ago
Yes, it's still a problem. Testcase in url field.
This regressed between 2006-01-25 and 2006-01-26, so almost certainly due to bug 31375.
Blocks: 317375
Posted patch fixSplinter Review
Simple fix. Bullets need to be able to accept events. They used to and I broke it.
Assignee: selection → roc
Status: NEW → ASSIGNED
Attachment #229990 - Flags: superreview?(dbaron)
Attachment #229990 - Flags: review?(dbaron)
Comment on attachment 229990 [details] [diff] [review]
fix

r+sr=dbaron.  Sorry for the delay.
Attachment #229990 - Flags: superreview?(dbaron)
Attachment #229990 - Flags: superreview+
Attachment #229990 - Flags: review?(dbaron)
Attachment #229990 - Flags: review+
checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.