'Multiple tabs, confirm close' dialog should list tab titles

UNCONFIRMED
Unassigned

Status

()

Firefox
Tabbed Browser
--
enhancement
UNCONFIRMED
12 years ago
4 months ago

People

(Reporter: thomasjf, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [wontfix?])

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

The 'Confirm close' dialog ("You are about to close X open tabs.  Are you sure you want to continue?") should list 

Reproducible: Always

Steps to Reproduce:
Enable 'multiple tabs open' warning on window close (browser.tabs.warnOnClose)
Open multiple tabs.
Close the window,
Actual Results:  
Shows dialog, summarizing # of tabs open in the window that is to be closed

Expected Results:  
Show dialog, summarizing # of tabs open, and also listing the titles of the tabs open in the window that is to be closed.
(Reporter)

Comment 1

12 years ago
The 'Confirm close' dialog ("You are about to close X open tabs.  Are you sure
you want to continue?") should list *the tab titles*.

( * text missing from original submission )

Comment 2

12 years ago
I consider this to be a bit of bloat. What happens if the user has 40 tabs open, list them all? I don't see what can be won from this.
(In reply to comment #2)
> I consider this to be a bit of bloat. What happens if the user has 40 tabs
> open, list them all? I don't see what can be won from this.
> 

Agreed.

Comment 4

12 years ago
Duplicate of/related to Core bug 235998?

Updated

10 years ago
Blocks: 439756
"Confirm close" popup already says how many tabs are being closed. Listing the titles of all the 150 or so tabs in my Firefox instance is certainly not what I want. I suggest this bug be resolved WONTFIX, leaving bug 235998 to add a "Details" button (which one may click only if desired).
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → Trunk
Whiteboard: [wontfix?]
You need to log in before you can comment on or make changes to this bug.