Copy bookmark ---> doesn't gracefully paste as plain text

VERIFIED FIXED

Status

SeaMonkey
Bookmarks & History
P3
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Eli Goldberg, Assigned: Robert John Churchill)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
* TITLE/SUMMARY
Copy bookmark ---> doesn't gracefully paste as plain text

* STEPS TO REPRODUCE
0) Launch Seamonkey
1) From the Bookmarks menu, select "Manage Bookmarks..."
2) Click on a bookmark, and select "Copy" from the Edit menu
3) Launch a text editor (SimpleText on Mac OS & WordPad on Windows)
4) Click "Paste" from the Edit menu.

* RESULT
 - What happened

On each platform, the following is pasted:
	ID:{http://home.netscape.com/bookmark/6_0b1/
entertainmentnews.html};NAME:{Entertainment News};

If copying a folder:
	ID:{NC:BookmarksRoot#$31bfecc7};NAME:{News and Sports};
	
If copying separator:
	ID:{NC:BookmarksRoot#$43924d82};NAME:{-----};

 - What was expected 

On Windows, IE specifically pastes bookmarks as URLs with icon. On Mac OS, 
there's no way I can find using Communicator or IE to copy an entire bookmark 
line, so graceful degradation of URLs to plaintext isn't an issue.

Thanks to mpt@mailandnews.com for suggesting this test case.

* REGRESSION

 - Occurs On
        Mac OS Seamonkey (3.21.00 AM optimized build)		
        Win32 Seamonkey (3.21.00 AM optimized build [NT 4, Service Pack 5])

 - Doesn't Occur On
        any other browser (IE 5 Win, IE 4.5 Mac, etc)

* CONFIGURATIONS TESTED

- [Mac] Beige Power Mac G3 (266 MHz PowerPC 750), 96 MB RAM (VM on; 1 MB of VM 
used), 1024x768 (Thousands of Colors), Mac OS 8.6

- [Win32] Vectra VL (233 MHz P2), 96 MB RAM, 800x600 (True Color), NT 4.0 SP5.

- [Linux] Vectra VL (266 MHz P2), 96 MB RAM. Red Hat Linux 6.0 (GNOME).
(Reporter)

Comment 1

18 years ago
QA Assigned self, CC:ing Matthew.
QA Contact: claudius → elig
Target Milestone: ---

Comment 2

18 years ago
And when pasting a bookmark into an HTML context (such as Composer), you should 
get <a href="bookmark URL">Bookmark title</a>.
(Assignee)

Comment 3

18 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

18 years ago
Hmm...this looks great on this morning's Mac OS Mozilla and Win32 commercial
builds.

(Specifically, I can copy a bookmark and paste it plaintext as URL, or as a link
into Composer as mpt suggests. Moreover, copying folders & separator bars
doesn't yield pasteable plaintext or rich text output.)

However, on this morning's Linux commercial build, bookmarks aren't copyable at
all, whereas other text is.

So, I'm re-opening this bug. rjc, I'd be happy to split off the Linux side-issue
into a separate bug report (and investigate it further) if you'd prefer.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 5

18 years ago
Err, I misspoke --- you can _copy_ bookmarks on Linux, but nothing comes out if 
you paste them. ;)
(Reporter)

Comment 6

18 years ago
Okay. There's a deeper copy/paste problem on Linux. Verifying this bug as fixed.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

18 years ago
I have to specify a comment on this change, so here are some meaningless words on 
the reason for my change.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.