Upgrade doctor.mozilla.org to latest version (like doctor.mozilla.com)

RESOLVED FIXED

Status

mozilla.org Graveyard
Server Operations
RESOLVED FIXED
13 years ago
3 years ago

People

(Reporter: reed, Assigned: justdave)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
Would it be possible to upgrade doctor.mozilla.org to the latest version of Doctor (as doctor.mozilla.com has)? The one on d.m.c looks much nicer and has quite a lot more features than the current version on d.m.o.

If this happens, the footer in the mozilla-org templates will need to be updated to use the format that the new Doctor version uses.
Assignee: server-ops → aravind
Assignee: aravind → justin
(Reporter)

Updated

12 years ago
Blocks: 292190

Updated

12 years ago
Component: Server Operations → Server Operations Projects
Doctor now supports multiple cvsroots/webroots.  We should upgrade doctor.mozilla.com to the new multi-root version (because it'll be easier to upgrade than doctor.mozilla.org since it's more-recent), then add the mozilla.org webroot to it, and point doctor.mozilla.org at that installation.
*** Bug 339645 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 3

12 years ago
(In reply to comment #1)
> Doctor now supports multiple cvsroots/webroots.  We should upgrade
> doctor.mozilla.com to the new multi-root version (because it'll be easier to
> upgrade than doctor.mozilla.org since it's more-recent), then add the
> mozilla.org webroot to it, and point doctor.mozilla.org at that installation.

Unless the SSL cert at doctor.mozilla.com is fixed, I'd say swap the above instructions. Upgrade and rename doctor.mozilla.com to doctor.mozilla.org (since the .org SSL cert works fine) and point doctor.mozilla.com to doctor.mozilla.org. I know Jesse was having a problem last night with doctor.mozilla.com having a bad SSL cert, so it's likely to cause problems for others, too.
(Reporter)

Updated

12 years ago
Assignee: justin → justdave
Component: Server Operations Projects → Server Operations
This is done.

doctor.mozilla.com now redirects to doctor.mozilla.org, and doctor.mozilla.org is configured to handle www.mozilla.org, www.mozilla.com, irc.mozilla.org, and the new www.bugzilla.org module.  It's extensible, if it's in cvs-www we can add it. :)

doctor has also migrated from rheet to recluse (because the SSL cert was available there), thus getting one more service off an old unsupported-hardware RHEL 2.1 box.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.