Last Comment Bug 326962 - Excessive amount of images on a page causes Firefox to chew away at memory and VM
: Excessive amount of images on a page causes Firefox to chew away at memory an...
Status: RESOLVED DUPLICATE of bug 213391
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Windows XP
: -- normal with 3 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-12 18:03 PST by Micheal Cottingham
Modified: 2006-03-14 13:27 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
PHP scripts to generate the testcase (805 bytes, application/x-gzip)
2006-02-12 18:04 PST, Micheal Cottingham
no flags Details

Description Micheal Cottingham 2006-02-12 18:03:17 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Attached is a gzip that will generate the test case. It is written in PHP. Works on Windows and Linux, just modify the paths.

Once generated, point your browser to the generated ffdos.html and watch the memory and virtual memory. Eventually Windows will warn you that it has to increase virtual memory and Firefox will continue to chew away until the process is killed. Tested on 3 Windows XP systems with Firefox 1.5.0.1 and 1 SuSE 9.3 with Firefox 1.5.0.1. Once killed, memory may return to normal or you may have to reboot in order to clear the leak.

I tried with this with just images, but the problem didn't reappear, it seems images and maps are necessary. On my system, I was able to get this working with the default 300 set in the scripts.

I attempted to follow http://dbaron.org/log/2006-01#e20060110a but was unable to get a log file generated.

Reproducible: Always

Steps to Reproduce:
1. Download the test case, launch the scripts and allow them to generate the images and html file.
2. Browse to the html file and watch the memory and processor usage
3. Memory will continue to climb until the process is killed while processor will generally stay near normal

Actual Results:  
Firefox consumes memory until process is killed.

Expected Results:  
Loaded the webpage and then cleared the memory once done.

The generated images are 1024x768 with a simple black background. Attempted to generate 2x2 images but results could not be duplicated.

Using the Noia 2.0 eXtreme 2.992 theme on this computer.
Comment 1 Micheal Cottingham 2006-02-12 18:04:26 PST
Created attachment 211665 [details]
PHP scripts to generate the testcase
Comment 2 Steve Chapel 2006-02-15 07:07:36 PST
This looks like a dupe of bug 213391. The images on the page are stored in the memory cache, and limiting the size of the memory cache would limit the memory use for images on the page in the testcase.
Comment 3 Steve Chapel 2006-02-24 04:45:25 PST

*** This bug has been marked as a duplicate of 213391 ***
Comment 4 Florian 2006-03-14 13:27:06 PST
I can Confirm this. The viritual memory is not clearing, and you must reboot the  PC, you can't do anything more when Firefox run.

Version

Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1


Note You need to log in before you can comment on or make changes to this bug.