Save Page As...: fails with "invalid byte sequence in conversion input"

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: andi, Unassigned)

Tracking

1.5.0.x Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME, URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1

Selecting Save Page As... in the context menu and then Save,
the following error message appears and the page does NOT get saved:

"Could not build file name from 'file:///home/amoh' and 'Flavio?s TechnoTalk » Blog Archive » Linux performance series: low-overhead statistical profiling with oprofile.html': Invalid byte sequence in conversion input"

Probably this error message occurs due to codepage conversion error of double quotes ('»') or single quote (''').

Reproducible: Always

Steps to Reproduce:
1. Visit the URL given above
2. In context menu, select Save Page As...
3. Press Save -> error message box



Expected Results:  
A properly saved web page

Semi-updated RHEL3 installation

$ locale
LANG=de_DE@euro
LC_CTYPE="de_DE@euro"
LC_NUMERIC="de_DE@euro"
LC_TIME="de_DE@euro"
LC_COLLATE="de_DE@euro"
LC_MONETARY="de_DE@euro"
LC_MESSAGES=en_US
LC_PAPER="de_DE@euro"
LC_NAME="de_DE@euro"
LC_ADDRESS="de_DE@euro"
LC_TELEPHONE="de_DE@euro"
LC_MEASUREMENT="de_DE@euro"
LC_IDENTIFICATION="de_DE@euro"
LC_ALL=
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
WFM. The saved file shows an exact duplicate of the website.
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a1) Gecko/20060213 Firefox/1.6a1
Works fine for me.
Have you tried this in safemode, or maybe tried saving to a different directory, hard drive, or mounted area?
Going on from that, how is the HDD on which you're trying to save formatted? ext3?
(Reporter)

Comment 5

13 years ago
(sorry for the delay)
Indeed, it's ext3.

Problem persisting in:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060314 Firefox/1.5
Reporter, do you still see this problem with Firefox 2.0? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME
Version: unspecified → 1.5.0.x Branch

Comment 7

11 years ago
No response, WFM → resolving WFM.

Feel free to reopen, if you can reproduce it with the latest Firefox 3 build. Though it's probably been caused by a non-Unicode locale.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.