Can not display JPG image.

RESOLVED DUPLICATE of bug 338462

Status

()

Core
ImageLib
--
major
RESOLVED DUPLICATE of bug 338462
13 years ago
12 years ago

People

(Reporter: Timothy Huang, Assigned: Stuart Parmenter)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060212 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060212 SeaMonkey/1.5a

I tried to display a jpg image (address as shown in the URL field above). The latest nightly buuilt won't display the target image, and give a message: The image "http://www.dinodragon.com/CERTIFicate.jpg" cannot be displayed, becaused it contains errors.

However, the same web address will show correctly with Safari.

Reproducible: Always

Steps to Reproduce:
1. Up load a jpg file to my website: www.dinodragon.com
2. trying to access this jpg image page
3.

Actual Results:  
Got a message: The image "http://www.dinodragon.com/CERTIFicate.jpg" cannot be displayed, becaused it contains errors.

Expected Results:  
The jpg image should be shown (as Safari).

Comment 1

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060212 Firefox/1.6a1

Same here.  So if there is an issue, likely to be core and all/all, I suspect.  The image opens fine for me if saved and then viewed using MS Picture Viewer.
MS Paint refuses to load this jpg too, yet IrfanView and Photoshop6 manage just fine.

Updated

12 years ago
Assignee: general → pavlov
Component: General → ImageLib
OS: MacOS X → All
Product: Mozilla Application Suite → Core
QA Contact: general
Hardware: Macintosh → All
Version: unspecified → Trunk

Comment 3

12 years ago
You may want to see a similar issue with a .bmp file: https://bugzilla.mozilla.org/show_bug.cgi?id=327074

Comment 4

12 years ago

*** This bug has been marked as a duplicate of 338462 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.