Master password entry dialog's "cancel" button doesn't work.

RESOLVED DUPLICATE of bug 275547

Status

RESOLVED DUPLICATE of bug 275547
13 years ago
13 years ago

People

(Reporter: jack, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060207 Firefox/1.5.0.1
Build Identifier: version 1.6a1 (20060210)

Pushing the "cancel" button on the master password dialog should not have to be repeated.  Clicking the cancel button results in the exact same dialog reappearing up to a variable number of times (apparently based on the "maximum number of server connections to cache" server setting).

Reproducible: Always

Steps to Reproduce:
1. Install and configure accounts for thunderbird
2. Configure a master password and log into account(s) at least once, storing your password(s)
3. quit thunderbird
2. start thunderbird
3. If "check for new messages at startup" is selected, do nothing.  If it is not selected, click on a folder.
4. The "Please enter the master password [. . .]" dialog appears
5. click cancel (* maybe you realize you need to look up a password or dial in to the VPN, or dont want to check your email at all)


Actual Results:  
The "Please enter the master password..." dialog reappears.

Expected Results:  
The "Enter your password" dialog should appear, as if you wanted to log in without using the master password.


If you wait a little while before clicking cancel, it will work the first time and not even fall back to the account password dialog.  I think it's about 30 seconds, but I didn't time it.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 275547 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.