focus()/:focus is broken for some elements when the window doesn't have focus

RESOLVED FIXED

Status

()

defect
--
minor
RESOLVED FIXED
14 years ago
2 months ago

People

(Reporter: mats, Unassigned)

Tracking

({testcase})

Trunk
x86
All
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.8.1.15 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

14 years ago
focus() is broken for some elements when the window doesn't have focus.
The :focus styling seems confused, it applies to multiple elements.

STEPS TO REPRODUCE
1. load attached testcase
2. click on the desktop background or a window of a different application
3. focus the window with the testcase again

ACTUAL RESULTS
2: The :focus outline/border is rendered for some elements even though they
   do not have focus, while for other elements the outline/border is not
   rendered when the element do have focus.
3. Now it works properly again.

EXPECT RESULTS
Same result with/without window focus.

PLATFORMS & BUILDS TESTED
Bug occurs in SeaMonkey 2006-02-11-02 trunk Linux
Bug occurs in Firefox 1.5 Linux
Reporter

Comment 1

14 years ago
Posted file Testcase

Updated

12 years ago
Duplicate of this bug: 371078

Comment 3

12 years ago
Setting OS to all as I see this on Windows too.
OS: Linux → All

Comment 4

12 years ago
Hm, Bug 371078 has been marked as duplicate, but there is one piece of information in it that isn't mentioned here. Namely, that if you press Alt-Tab while a drop-down box is dropped down, it loses focus. Is this covered in another bug, or should I report this separately?

Comment 5

12 years ago
I see that problem with 1.5 (and I presume with 2.0) but not with Minefield.  In minefield I only see the problem with multiple form items able to have :focus applied.  I'm not sure what fixed the focus problem or if that would be fixable in released versions.  

Comment 6

11 years ago
This problem still occurs in Firefox 3 beta 5.

Updated

11 years ago
Flags: blocking1.8.1.15?
not blocking a branch release, will take it when it's fixed on trunk.
Flags: blocking1.8.1.15? → blocking1.8.1.15-

Updated

10 years ago
Depends on: 178324

Comment 8

10 years ago
This bug should have been fixed by 178324.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Component: Event Handling → User events and focus handling
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.