title of checkbox not shown if checkbox is disabled

RESOLVED DUPLICATE of bug 274626

Status

()

Core
Event Handling
RESOLVED DUPLICATE of bug 274626
12 years ago
11 years ago

People

(Reporter: per.walstrom, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Opera/8.0 (Windows NT 5.1; U; en)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

When a checkbox is disabled, the title is not shown. E.g.

<input type="checkbox" name="csqUmm" value="on" checked="checked" disabled="disabled" id="csqUmm204" title="Urgent Market Message">

Opera (8.51) and IE (6) show the title even if the checkbox is disabled


Reproducible: Always

Steps to Reproduce:
1. use a form with a disabled checkbox
2. put a title to the checkbox
3. title is not shown when hovering over the checkbox

Actual Results:  
title is not shown when hovering over the checkbox

Expected Results:  
title should be shown when hovering over the checkbox
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060213 Firefox/1.6a1 ID:2006021314

Concur. With IE6.5 and Opera9tp2 a tooltip is shown when hovering over the disabled checkbox. With firefox it is not.
Component: Form Manager → General

Updated

12 years ago
QA Contact: form.manager → general
Probably a duplicate of bug 274626, which ought to be resummarized as "Disabled form controls..."
Assignee: nobody → events
Component: General → Event Handling
OS: Windows XP → All
Product: Firefox → Core
QA Contact: general → ian
Hardware: PC → All
Version: unspecified → Trunk

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 274626
You need to log in before you can comment on or make changes to this bug.