the block box width is shrunken if the parent box has 'shrink-to-fit' width and overflow != visible

RESOLVED DUPLICATE of bug 325680

Status

()

Core
Layout: Block and Inline
RESOLVED DUPLICATE of bug 325680
12 years ago
12 years ago

People

(Reporter: masayuki, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows 2000
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

The child block box is shrunken to the content width when the parent width is 'shrink-to-fit' and the parent overflow isn't 'visible'.

See the testcases.
Created attachment 211858 [details]
test case of the positioned boxes
Created attachment 211859 [details]
test case of the floting boxes
In both cases, the red border boxes on 2nd, 3rd and 4th box are shrunken to its content width. But if the parent overflow value is 'visible' or the parent width is not auto, the red border boxes are rendered correctly.

Updated

12 years ago
Keywords: testcase

*** This bug has been marked as a duplicate of 325680 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.