Firefox doesn't remember the title of some pages

RESOLVED FIXED in Firefox 2 alpha1

Status

()

P2
normal
RESOLVED FIXED
13 years ago
9 years ago

People

(Reporter: mossop, Assigned: brettw)

Tracking

({fixed1.8.1})

Trunk
Firefox 2 alpha1
x86
Windows XP
fixed1.8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
Some pages are appearing in the history as "(no title)". I can't see any logical reason for this. I even have two separate entries that are the same apart from the fragment and one has it's title correct and the other doesn't.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060213 Firefox/1.6a1
I think this is related to redirect handling. Brett can say. 
Assignee: nobody → brettw
(Reporter)

Comment 3

13 years ago
*** Bug 327419 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

13 years ago
Priority: -- → P2
Target Milestone: --- → Firefox 2 alpha1

Comment 4

13 years ago
I can confirm this on Windows XP, my Places view is littered with "(no title)" entries. I use Slashdot.org as my home page, and that consistently comes up as "(no title)" when I first start up the browser and open the Places view.
(Assignee)

Comment 5

13 years ago
I believe some people are getting no titles due to incorrect handling on history import where it thought you had set the user defined title to the empty string when it should have set it to NULL.

This patch fixes that problem and also removes some printfs.

For users that have them, the empty titles will persist. You'll have to delete your .sqlite file to reset them.
Attachment #213367 - Flags: review?(annie.sullivan)

Updated

13 years ago
Attachment #213367 - Flags: review?(annie.sullivan) → review+
(Assignee)

Comment 6

13 years ago
On branch and trunk
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED

Comment 7

13 years ago
Just wanted to verify that since this patch landed (and I deleted my .sqlite files), I haven't seen a single "(no title)" in Places.
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.