[testcases] With java disabled wrong information is displayed.

VERIFIED DUPLICATE of bug 114641

Status

Camino Graveyard
Page Layout
VERIFIED DUPLICATE of bug 114641
12 years ago
12 years ago

People

(Reporter: Matthew McGillis, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060214 Camino/1.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060214 Camino/1.0

Camino does not display proper content for applets when java is disabled. Fails test case specified in URL.

Reproducible: Always

Steps to Reproduce:
1. See test case for steps.
2.
3.

Actual Results:  
HTML between applet tags is not getting displayed.

Expected Results:  
HTML between applet tags should get displayed.

Comment 1

12 years ago
Confirming with 1.0 on 10.4.4.

Possible JEP problem?

Reporter, does this happen in Firefox 1.5?

cl
Status: UNCONFIRMED → NEW
Component: Page Layout → Plug-ins
Ever confirmed: true
(Reporter)

Comment 2

12 years ago
Yes this is also happens in Firefox 1.5.

Comment 3

12 years ago
OK, we can boot this to Core, then. Sam, you wanna do the honours? :)

cl
I can't confirm this report.

With Java disabled I see the alternate text that the page says I should see.
Tested with Camino 1.0RC1 and Firefox 1.5.0.1 on Mac OS X 10.4.4.

Moreover, even if I _had_ seen problems, they couldn't have been the fault of
the JEP -- when Java is disabled, the JEP isn't active!  (If you disable Java
while the browser is running, though, you do have to reload the page to have
your settings change take effect.  Same thing is true in Safari, and if you
remove the JEP and use Java 1.3.1 in Camino or Firefox.)

I just retested with Camino 1.0.  Same results -- I didn't see this problem.

OK, now I understand the problem.

I see the alternate text ([The 'Jitter Text' Java Applet!]) but not the
paragraph "The JitterText applet ... resumes the animation" (which, though it
isn't alternate text, is inside the applet tag).

Still, though, this doesn't (and can't) have anything to do with the JEP.

Comment 7

12 years ago
Yeah, it took me a minute to figure out what was wrong there too. The testcase isn't the most clearly written testcase I've ever seen ;)

I'm with Steven; I sort of doubt this is a JEP problem now.

cl
This belongs in Core somewhere (Layout?), assuming the testcases are still valid (lot of old testcases on m.org are hanging around and bad/not valid).

Someone should check this on the trunk, too, as plugin fallback was one of the Acid2 issues roc and friends were working on, iirc.
Component: Plug-ins → Page Layout
Keywords: qawanted
Per bz in bug 114641 comment 37, the trunk is now behaving properly.  That crappy testcase could do with an update, though.

*** This bug has been marked as a duplicate of 114641 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Keywords: qawanted
Resolution: --- → DUPLICATE

Updated

12 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.