Closed Bug 32719 Opened 20 years ago Closed 20 years ago

menus missing entirely from View Source Window, keyboard shortcuts busted

Categories

(SeaMonkey :: UI Design, defect, P2, critical)

defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 26593

People

(Reporter: sidr, Assigned: bugs)

References

()

Details

(Keywords: regression)

2000-03-21-08-M15 on Windows NT

The menus for the View Source window are now missing entirely. It seems that
they have been removed in two stages in versions 1.15 and 1.16 of 
viewSource.xul.

There is a fair bit of evidence that menus are intended to appear. The cvs log
for ver 1.14 shows "Minor fix to make viewSource window use overlay for View 
menu" and for 1.4, "Phase 1 of menu landing."
Based on the fix for bug 13535, "Find in View Source does find in the view 
souce window", it seems that the ability to search in the source window is
intended. Bug 26593, "^C doesn't work on view source window." needs Edit>Copy 
as a workaround, if it is still a problem on any platform.

On the other hand, the entire Go, Bookmarks, and Tasks menus are not 
particularly useful in the context of viewing source, and a number of
items could be removed from the File, Edit, and View menus.

Bug 24256, "View>Page Source can be recursive, probably shouldn't be" and
bug 31520, "In view-source, go menu has separator" apply to menus in the 
View source window, and can be closed out if this report is resolved as
WONTFIX.
QA Contact: paulmac → sairuh
Target Milestone: ---
keyboard shortcuts (eg, Alt+W to close) don't work anymore, either.

should this be reassigned to bill?
Severity: normal → critical
Keywords: regression
By rights, this would go to Travis.  I believe he changed the viewsource xul 
scheme recently to utilize base docshell function rather than code in 
nsBrowserInstance (at least that was my take on it).

Anyway, some of the stuff needs to be redone.  Ben would probably be best at it.  
I'm willing to do it if that's the best allocation of resources.  Ben can 
reassign as he sees fit.
*** Bug 33676 has been marked as a duplicate of this bug. ***
Priority: P3 → P2
Target Milestone: --- → M16
M16.  Ben, re-assign as you see fit.

View source window shouldn't have menu items. Confirmed by German.
updated summary.

if it ends up that we don't put the menus back into View Source, okay --but
keyboard shortcuts should still be enabled (see bug 33676, which was made a dup
of this one).
Summary: Menus missing entirely from View Source Window → menus missing entirely from View Source Window, keyboard shortcuts busted
people should cc themselves on the bug for keybindings in view source window (bug 
#26593) if so desired


*** This bug has been marked as a duplicate of 26593 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
verif.
Status: RESOLVED → VERIFIED
Looks like discussion is continuing in bug 63026.
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.