When trusting SpamAssassin junkmail headers, some SPAM is allowed

RESOLVED WORKSFORME

Status

Thunderbird
General
--
enhancement
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Steven Hunter, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: version 1.5 (20051201)

If a message is not flagged by SpamAssassin and the bayesian filter is enabled, those messages SpamAssassin does NOT flag as SPAM should be scanned by the bayesian filter. See also comment #4 in bug 224318. In other words, Thunderbird should optionally only trust positive SpamAssassin flags.

Reproducible: Always

Steps to Reproduce:




Due to the changing nature of SPAM I actually cannot verify that Thunderbird is or is not doing this. But ever since I told TB to trust SpamAssasin I have been getting more and more un-flagged SPAM in my Inbox.

Comment 1

13 years ago
you can use the config editor to do just that - 

user_pref("mail.server.serverXX.serverFilterTrustFlags", 3);

where serverXX is the incoming server - change the 3, which means trust positive and negative, to 1, just trust positives.

there's no UI for this since we felt it's a power user feature. But I did write a backend for it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

13 years ago
Excellent, thanks for the tip!
You need to log in before you can comment on or make changes to this bug.