All users were logged out of Bugzilla on October 13th, 2018

German in-tree calendar L10n is incomplete

RESOLVED FIXED

Status

RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: mozilla, Assigned: kairo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

13 years ago
The undo and redo properties are missing from the de-AT menuOverlay.dtd.
(Reporter)

Comment 1

13 years ago
Created attachment 211913 [details] [diff] [review]
patch against trunk

Although I noticed that when building the calendar extension from the 1.8.0 branch, this patch was done against trunk but it should work in the branches, too.
(Reporter)

Comment 2

13 years ago
Hups, now that I uploaded the patch I notice that there are many more entities missing from the de-AT locale, most calendar pref panel pages cannot be displayed in German.
(Reporter)

Comment 3

13 years ago
Created attachment 211916 [details] [diff] [review]
These should be all missing strings

KaiRo, are you the one to review this and check this in?

I was also wondering why all the timezones are in prefs.dtd but none of them is translated...
Assignee: kairo → mozilla
Attachment #211913 - Attachment is obsolete: true
Status: UNCONFIRMED → ASSIGNED
Attachment #211916 - Flags: review?
(Reporter)

Updated

13 years ago
Attachment #211916 - Flags: review? → review?(kairo)
(Assignee)

Comment 4

13 years ago
Comment on attachment 211916 [details] [diff] [review]
These should be all missing strings

I have all missing entieties in my local tree, but we are not allowed to check in anything to calednar localizations at the monet, so I guess the whole bug in INVALID unfortunately :(

(I have tried numerous times in recent weeks to persuede folks that I can update calendar L10n in the mozilla.org trees, but all attempts were denied...)
Attachment #211916 - Flags: review?(kairo) → review-
(Reporter)

Comment 5

13 years ago
Ah, but then why didn't you open a bug with an easy to find summary and attach your patch, then I would not have wasted half an hour at a time when I should have been in bed sleeping. Or was I just too tired/stupid to find that bug? ;-)
Assignee: mozilla → kairo
Status: ASSIGNED → UNCONFIRMED
(Assignee)

Comment 6

13 years ago
I usually don't file a bug for simple L10n updates...
In this case, it might have been a good idea nonetheless, so one could search for why it's not up-to-date yet, but I assumed noone is really using the in-tree L10n anyways. My "nightly" language packs on www.seamonkey.at contain complete localizations of calendar in the mean time, as long as I can't check them in.
This basically depends on bugs 281935 and 267981 - once those, esp. 267981, have been solved, calendar L10n checkins will be allowed again.
Status: UNCONFIRMED → NEW
Depends on: 267981
Ever confirmed: true
Summary: Strings in Calendar menuOverlay.dtd are missing → German in-tree calendar L10n is incomplete

Comment 7

13 years ago
*** Bug 328043 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 8

13 years ago
I forgot to mention here that the 1.8 branch has a current up-to-date calendar L10n in the tree again now, but the calendar people told me to leave trunk alone for now until they have finished bug 267981 (and land it on /1l0n tree then).
*** Bug 329594 has been marked as a duplicate of this bug. ***
Blocks: 330047
Created attachment 224691 [details] [diff] [review]
diff of de that would be committed in The Big l10n Move

Posted solely for KaiRo to diff his local changes against
No longer depends on: 267981
(Assignee)

Comment 11

13 years ago
A complete set of German (de) calendar files is in /l10n now, Thorsten and me will work together on some fine-tuning to it, but everything should build and work.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.