Make javascript execution independent of browser UI and other tabs

RESOLVED DUPLICATE of bug 718121

Status

()

Core
JavaScript Engine
--
enhancement
RESOLVED DUPLICATE of bug 718121
13 years ago
5 years ago

People

(Reporter: Lupin.wp, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060110 Debian/1.5.dfsg-4 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060110 Debian/1.5.dfsg-4 Firefox/1.5

It's trivial to freeze the entire browser from javascript with an infinite loop or a computationally infeasible regexp (see bug 307456).

I'd like the execution of a script in one tab to only block interaction with that tab. Other tabs and the browser UI should remain functional even when an infinite loop or nasty regexp are executed. 

In particular, it should be possible to close a misbehaving tab, thus aborting a blocking script.

Reproducible: Always

Steps to Reproduce:
see bug 307456
Go supersnappy!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 718121
You need to log in before you can comment on or make changes to this bug.