Manual internet connection set results in smtp mail send fail

RESOLVED WORKSFORME

Status

Thunderbird
General
RESOLVED WORKSFORME
12 years ago
8 years ago

People

(Reporter: peter.de.groot, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2008-09-11)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1




When I manually configure the proxy settings for TB connection to the internet,
I cannot sent mail via smtp to EITHER of my outgoing servers.

Changing the connect to internet to direct connection fixes the problem.

I have 2 IMAP accounts and 2 smtp servers.


Reproducible: Always

Steps to Reproduce:
1.Go to to options and select the connect to internet button
2.Select manual proxy config and type in an IP. Click button for same
proxy for all protocols
3.Try to send mail
4. It times out saying that the smtp mail server is not available and to
   check the settings.
5.  Try the other SMTP account .. no better
6. Go back to the proxy connection option and select the direct connection
   button
7. Works

Comment 1

12 years ago
Duplicate of bug 322719?
(Reporter)

Comment 2

12 years ago
YOu have a choice.. either connect to IMAP servers or to Internet proxy.
Setting a manual proxy results in time-outs to IMAP server.
This is a REAL pain, as a lot of email includes internet images etc

Is a fix far away .. he plantively asks ??
Peter

(Reporter)

Comment 3

12 years ago
Tried the latest  nightly  20060705.  Seems fixed... EXCEPT
after sending mail to the smtp server .. TB crashes :-(

BTw ... need proxy setting option in the quality feedback agent..
It seems to depend on the TB setttings ...
(Reporter)

Comment 4

12 years ago
Ah ha  !! .... possibly more info ???

Running lastest nightly  20060710 ?

Our internet proxy server requires a log in and password.

I know ... I know .... do not ask :-(

Anyway .. if I start Firefox and punch in the proxy username/password
then the connection to the proxy/net in TB apppears to work ! Yippee !!

So it seems that TB does not like to have a proxy login box.
Mind you .... I can sometimes "jag" it.

Peter
(Reporter)

Comment 5

12 years ago
Sorry.... I may be mistaken :-(  sigh.. I was so excited too...

It seems to re-used cached web stuff ok..
(Reporter)

Comment 6

12 years ago
Using nightly 20070727.

Seems to work if I use the proxy.pac to define my proxy
server .... if I manually set it .... falls over ...

Interestingly ..... If I manually set the proxy, it seems to work,
but when I select another IMAP folder or send an email, it fails with
a time out..

Still .... this is some progress....
(In reply to comment #6)
> but when I select (snip) send an email, it fails with a time out.

Similar timeout to Bug 325649?
Get NSPR log with timestamp of nsSocketTransport:5,nsHostResolver:5 in addition to IMAP:5,SMTP:5.
 - See Bug 86396 comment #7 for NSPR log with timestamp on MS Win
 - See http://www.mozilla.org/projects/netlib/http/http-debugging.html
   for nsSocketTransport:5,nsHostResolver:5

Updated

9 years ago
Assignee: mscott → nobody
Reporter, does the issue still occur in the latest supported 2.0.0.x / Shredder trunk nightlies?

(1.5.0.x is now end-of-life and the latest supported 2.0.0.x is version 2.0.0.16)
Whiteboard: closeme 2008-09-11
(Reporter)

Comment 9

9 years ago
Mmm... it "seems" to be working ok now...

I am running 2.0.0.16, as per the automagic update....

Is possible it is still using cached passwords..

WIll be in touch,
RESO WFM per comment 9.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.