Unable to insert image file when preferences set to Plain text

VERIFIED INVALID

Status

P3
normal
VERIFIED INVALID
19 years ago
6 years ago

People

(Reporter: marina, Assigned: bugzilla)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
**** observed with 2000-03-21 win build ****
Steps to reproduce:
-set preferences in pref.js file to html=false;
-open new mai;l composition;
-click Insert|Image...
-chose your image file;
- OK the dlgbox;
//note: when trying to hit Ok dlgbox is not closing, you can dismiss it by 
chosing "cancel"
(it is possible to insert an image file into new mail when preferences are set 
to HTML=true)
(Reporter)

Comment 1

19 years ago
Created attachment 6758 [details]
this is an image file i used for testing

Comment 2

19 years ago
The insert options are invalid for a plain text composition window.  The entire
Insert menu should be disabled.  I'll check for an existing bug...
Target Milestone: ---

Comment 3

19 years ago
OK, I checked with nbaca and there's no existing bug about this.  Basically, it
looks like we haven't yet implemented a differentiating menu set for plain text
vs. html message composition window.  In current builds both the Insert and
Formatting menu items are all present and enabled.  There may be more...

QA assigning to nbaca and she can handle
QA Contact: lchiang → nbaca

Comment 4

19 years ago
made an entry in mailnews release notes
Keywords: relnote

Comment 5

19 years ago
A bug for removing the HTML menu options, such as the Insert menu and the Format
menu, is logged in bug# 24185.

Comment 6

19 years ago
reassign to ducarroz.
Assignee: selmer → ducarroz
(Assignee)

Comment 7

19 years ago
Accepting, M17
Status: NEW → ASSIGNED
Target Milestone: --- → M17

Comment 8

19 years ago
Minor UI fixups to M18.  If this is incorrect, please adjust.
Target Milestone: M17 → M18

Comment 9

19 years ago
Why is this bug even still open?  This is an invalid situation and the fact that
the menu is incorrect is already covered in another bug! I'm marking this as
resolved/invalid.  
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID

Comment 10

19 years ago
Verified Invalid.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.