Need a way to log into a web site using Thunderbird for RSS

RESOLVED DUPLICATE of bug 1060754

Status

--
enhancement
RESOLVED DUPLICATE of bug 1060754
13 years ago
2 years ago

People

(Reporter: a, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Some feeds require web-style login. For example:

http://www.flickr.com/news.gne#193
http://iraq.page.nytimes.com/b/a/238447.htm

There is no way to log into a site using Thunderbird. The cookies are disabled by default, and all hyperlinks are redirected to Firefox.

The workaround right now is summarized at:
http://kb.mozillazine.org/RSS_cookies_(Thunderbird)

This workaround is rotten. It enables cookies in both email and RSS.

What we really want is to enable login on a per-feed basis. If we knew what feeds required login, when subscribing you could:
- pop up a browser window asking the user to log in. The default url can be the channel page.
- enable any cookies coming through this page. The functionality to restrict cookies like this already exists.

This should not be too hard to do. I'd volunteer if someone can give me a few pointers: where is the enable/disable cookie API


Reproducible: Always

Comment 1

13 years ago
Duplicate of/related to bug 318104?

Comment 2

13 years ago
Yes, same basic problem -- but, as I said at that bug, either these are 
actually dupes of bug 242974 or are WontFix because browsing in the mail 
client is not really a viable solution.

Comment 3

12 years ago
The poster doesn't seem to be looking for the addition of any actual browser controls, merely the addition of an option to allow the sharing of cookies between Thunderbird and the system's browser, on a per-feed basis.  It could be a simple check box in the 'Feed Properties', much like the currently existing 'Show the article summary instead of loading the webpage' option (although these two options would be mutually exclusive).  Heck, I doubt anyone would even complain if this particular functionality only worked in conjunction with Firefox.  All other page-display functionality would (and should) remain untouched (i.e. links opening in the default browser).

Is there something about the nature of the page retrieval functions, within Thunderbird, that precludes handling cookie requests?

As for the bugs listed in Comments #1 & #2, it seems the actual problem is the same but this poster's suggested fix is relatively unique.  For the record, Comment #2 on bug 318104 (posted by Jean-Michel Reghem) referred to the SeaMonkey fix, and is where I got the cookie sharing idea.

Comment 4

10 years ago
(In reply to comment #3)
> The poster doesn't seem to be looking for the addition of any actual browser
> controls, merely the addition of an option to allow the sharing of cookies
> between Thunderbird and the system's browser, on a per-feed basis.  It could be
> a simple check box in the 'Feed Properties', much like the currently existing
> 'Show the article summary instead of loading the webpage' option (although
> these two options would be mutually exclusive). 

Bryan, thoughts?  I can't imagine thunderbird ever getting to that level of complexity, except perhaps via an extension.
OS: Windows XP → All
Hardware: PC → All
Summary: Need a way to log into a web site using Thunderbird → Need a way to log into a web site using Thunderbird for RSS
Assignee: mscott → nobody

Updated

10 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core

Comment 5

2 years ago
Both javascript and cookies are enabled for feed web pages. The problem is keyinput intercepts for html form elements.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1060754
You need to log in before you can comment on or make changes to this bug.