caracters disapear when putting exacly 32761 or more caracters on 1 line in an textarea

RESOLVED DUPLICATE of bug 305264

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 305264
12 years ago
12 years ago

People

(Reporter: Cybertinus, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

If you put 32761 or more caracters on 1 line in an textarea, then the last caracters disapear. If you walk, with the cursor from the beginnen of the line to the end, then you see all the caracters, except for the last part of the line. A part is everything of the line you can see on 1 screen, without scrolling.
If you walk the line from the end to the beginning, you see 1 part, then you have a part you can't see, then you see the text, then you don't see the text, and so on, and so on.

Reproducible: Always

Steps to Reproduce:
1. Go to the website stated above
2. Copy the 32761 caracter line to the text area

Actual Results:  
the caracters pasted in the textarea disapeared

Expected Results:  
the caracters should have stayed visible

Comment 1

12 years ago
I think this is a bug in windows widget. I'm seeing this in some other applications.

Perhaps related to the kind of widget used.
Created attachment 212020 [details]
Showing the problem

Another confirm; Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9a1) Gecko/20060215 Firefox/1.6a1

Two more bugs: the example text appears for a while, then just shows as blank spaces. When I viewed the source to get it that way, only part of the example text showed up; the rest was rendered as spaces and the code showed two instances of "br>" at the end of the example line. See accompanying grab for more details.

Comment 3

12 years ago
See meta bug 302294, duplicate of/related to one of those bugs (and/or their many duplicates)?
Quite possibly one of the deeper ones, but certainly bug 305264

*** This bug has been marked as a duplicate of 305264 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.