If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

mouse wheel doesn't work if mouse cursor is over <caption> elements.

RESOLVED WORKSFORME

Status

()

Core
XUL
RESOLVED WORKSFORME
12 years ago
8 years ago

People

(Reporter: Nico, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060127 SeaMonkey/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060127 SeaMonkey/1.0

In a page which contains <caption> elements in <img> or <table> tags, the mousewheel stops working if the mouse cursor is over the <caption> element. Scrolling works as expected if the cursor is somewhere else, though.


Reproducible: Always

Steps to Reproduce:
1. Got to http://www.useit.com/papers/heuristic/heuristic_evaluation.html and put your mouse cursor over the text (!) "Figure 1".
2. Move your mouse wheel


Actual Results:  
Nothing happens.

Expected Results:  
Page should scroll.

This can be reproduced with Firefox 1.5 and SeaMonkey 1.0 (at least) on win32.
(Reporter)

Comment 1

12 years ago
Created attachment 211982 [details]
stripped down testcase
(Reporter)

Comment 2

12 years ago
Created attachment 211983 [details]
working stripped down testcase

The testcase above doesn't reproduce the bug - strange, because only the text in the table and in the caption is different from this version...
(Reporter)

Comment 3

12 years ago
The second attachment doesn't reproduce the bug as well if you view it by clicking on it. You have to open it, save it to your hard disk and open the file from your harddisk to reproduce the bug (if you still can't reproduce it, ctrl-reload the local file). It's probably easier to use the url given in comment #1.

Sorry for the bugspam.
(Reporter)

Comment 4

12 years ago
Created attachment 211988 [details]
working stripped down testcase

This should reproduce the bug directly. Seems as if quirks mode has to be used to make this bug visible.
Attachment #211982 - Attachment is obsolete: true
Attachment #211983 - Attachment is obsolete: true
(Reporter)

Comment 5

12 years ago
ARGH. No, still doesn't work. It works if you load the test case from here, though:
http://www.amnoid.de/tmp/scrollbug.html

(again sorry for the spam)
confirming

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060208 SeaMonkey/1.5a
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

12 years ago
confirming for
http://www.useit.com/papers/heuristic/heuristic_evaluation.html

Mozilla/5.0 (BeOS; U; BeOS BePC; en-US; rv:1.9a1) Gecko/20060206 SeaMonkey/1.5a

Updated

9 years ago
Assignee: jag → nobody
-> WFM

I cannot reproduce this bug on 20101116042715-trunk/Win7.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.