mailman <-> nntp gateway should reject messages with attachments

RESOLVED FIXED

Status

mozilla.org Graveyard
Server Operations
P1
normal
RESOLVED FIXED
11 years ago
2 years ago

People

(Reporter: beltzner, Assigned: justdave)

Tracking

Details

(Whiteboard: Completed by the 21th)

If I send an email with an attachment to dev-apps-firefox@lists.mozilla.org that email doesn't seem to make it out to the list nor to the usegroup. This has apparently been experienced in other places as well. The specific thread in which this most recently occured to me is:

http://groups.google.com/group/mozilla.dev.apps.firefox/browse_frm/thread/cc8910555d55bbc4/b4667beee43e3c14#b4667beee43e3c14
Ah, it didn't drop it, it held it:
-------------
Your mail to 'dev-apps-firefox' with the subject

   Re: Bookmarks/History Management: Tab or Window?

Is being held until the list moderator can review it for approval.

The reason it is being held:

   Message body is too big: 143306 bytes with a limit of 40 KB

-------------

Any way we can get that limit upped a little? 40KB is quite small.

Comment 2

11 years ago
Mailing list is one thing. Giganews has a separate filter, based (I believe) on content-type, and so does Google. Generally speaking, if the attachment can be viewed and edited with a text editor, it will pass through. These include TXT, CSS, and ICS files, vCards, PGP (inline) or GPG signatures, and HTML posts. Even though I've seen a few S/MIME signed messages from the mailing list, make it to the news server, they will not make it to Google either.

I assume this will be marked as WONTFIX.
Yeah, Chris is correct, I had that on my followup agenda for the loose ends I still needed to clean up to get all the lists configured to reject messages with attachments (because Giganews won't allow them anyway).  Since I didn't actually have a bug for it though I'll make this it.
Assignee: server-ops → justdave
Summary: mailman <-> nntp gateway drops messages with attachments → mailman <-> nntp gateway should reject messages with attachments
Priority: -- → P1
There have been issues with base64-encoded text getting filtered as attachments...

The current mailman apparently does have the capability to re-encode messages as plaintext on the way through the server, so we should probably try to get that working as well, and in the chain prior to stripping or rejecting attachments.
*** Bug 329781 has been marked as a duplicate of this bug. ***
Filed bug 332584 as per comment 4
(In reply to comment #6)
> Filed bug 332584 as per comment 4

Why?  It's the same setting in mailman, so it'll get fixed at the same time.  It's just which way to set it. :)
Blocks: 332584
Er, I filed a different bug because this one is called something entirely different and talks about rejecting binary attachments.

Updated

11 years ago
Whiteboard: Completed by the 21th
The support-bugzilla (relatively high traffic) and support-webtools (almost no traffic) mailing lists have been set to reject non-text attachments and convert html to plain text.  I'll watch it tomorrow and if there's no major problems I'll clone the settings to the rest of the lists.
Status: NEW → ASSIGNED
Haven't heard of any problems, so I've flipped the switch on the rest of them.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
just for the record, test-multimedia is "special" and it got left alone.
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.