Parent list objects Underline style affects all no matter what

RESOLVED INCOMPLETE

Status

()

Firefox
General
RESOLVED INCOMPLETE
12 years ago
11 years ago

People

(Reporter: ryan ternier, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 06/27)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

IF you have an ordered list:
<ol>
<li style="text-decoration:underline;">Something here That should be underlined
<ol><li style="text-decoration:none;">This should not be</li></ol></li></ol>

The Underline from the parent goes to the child, even when the child said no underline.

Even if you had the child:
<li style="text-decoration:none;"><span style="text-decoration:none;">This should not be underlined </span></li>

It will still be underlined because of the parent.

Reproducible: Always

Steps to Reproduce:
1. Look at my details
2.
3.



Expected Results:  
It should not have underlined the child list item.

Comment 1

12 years ago
I have a problem that seems to be an instance of this feature:
If I have a link containing image+text I can't stop it underlining the image.
This only happens with a proper doctype (ie non-quirks mode).
It's correct (but ugly) behaviour, as per http://www.w3.org/TR/CSS21/text.html#lining-striking-props 
and therefore should not be changed.
Can use display:block or similar to workaround.

http://services.ccagroup.co.uk/testlink3.html
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html><head><meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"><title>test link</title>
<style type="text/css"><!--
a img.nound { text-decoration: none; border: none; }
// -->
</style>
</head>
<body><p><a href="#"><img src="pos/ccastat_logo.gif" alt="testA1" title="testA1">testA1</a><br>
<a href="#"><img src="pos/ccastat_logo.gif" alt="testA2" title="testA2"></a><br>
<a href="#">testA3</a></p>
<p><a href="#"><img src="pos/ccastat_logo.gif" class="nound" alt="testB1" title="testB1">testB1</a><br>
<a href="#"><img src="pos/ccastat_logo.gif" class="nound" alt="testB2" title="testB2"></a><br>
<a href="#">testB3</a></p>
</body></html>
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 06/27
Version: unspecified → 1.5.0.x Branch

Comment 3

11 years ago
Gave reporter adequate time to respond. Resolving incomplete.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.