If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

closing tabs causes the last tab to not be displayed (blank screen instead) on certain websites

RESOLVED INVALID

Status

()

Firefox
Tabbed Browser
--
minor
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Dak, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Not sure of the exact terminology, so i appologise if this is a dupe. 

Certain sites (mediawiki sites and bugzilla are the only ones i've found sofar) cause a tab to not be displayed if the penultimate tab is closed: the beigue blank screen is displayed instead.

Reproducible: Always

Steps to Reproduce:
1.close all tabs bar one
2.visit a media wiki site, such as wikipedia... also works for me on this site (ie, bugzilla)
3.press ctrl + tab to open another tab
4.ensure that the mediawiki/bugzilla tab is on the left, and the new one on the right.
4.make sure that the new tab has focus. doesnt matter wether a site is displayed in the new tab or not.
5. close the new tab whilst it has focus.
Actual Results:  
tab bar dissapears (as it should when only one tab is open)

beigue blank-screen is displayed -- title bar reads 'mozilla firefox'

Expected Results:  
tab bar dissapears

wikipedia page/bugzilla page should be displayed

workaround/recovery:

1. press ctrl+t to open a new tab.
2. not that the original tab now reappears.
3. focus the original tab
4. close the other tab whilst the mediawiki/bugzilla page has focus

if you require info on my extentions, just ask.
(Reporter)

Comment 1

12 years ago
Actually, after further investigation, it seems to be a bug with tab mix plus 0.3.0.3. (problem goes away after disabling this extention, and returns upon re-enabling)

Is this the right place to report bugs with the extentions, or should i report it directly to them?
(Reporter)

Comment 2

12 years ago
the developers of the extension seem to be aware of this.

feel free to close this bug (i'll leave it open in case it highlights an underlying prob with FF or something)

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.