browser crashes when viewing files at zdnet.com

VERIFIED WORKSFORME

Status

()

P3
major
VERIFIED WORKSFORME
19 years ago
19 years ago

People

(Reporter: bugzilla, Assigned: kmcclusk)

Tracking

({crash, platform-parity})

Trunk
Other
Linux
crash, platform-parity
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Pavlov and Waqar are looking at the problem., URL)

(Reporter)

Description

19 years ago
saw this while using the beta1 branch bits (opt, comm) on linux,
2000.03.21.05-nb1b. not a problem on the equivalent bits on winNT or mac.

go to the above URL
(http://www.zdnet.com/pcweek/stories/news/0,4153,2449321,00.html), and the
browser crashes. jrgm thinks this is a layout bug, so assigning it to that
component.

btw, has this been seen before?

talkback report #7253289:
http://cyclone/reports/incidenttemplate.CFM?reportID=124&style=0&tc=49&cp=1&ck1=SUser+email+address&cd1=%25sairuh%40netscape%2Ecom%25&co1=like&bbid=7253289

 Trigger Type:  Program Crash 

 Trigger Reason:  SIGSEGV: Segmentation Fault: (signal 11) 

 Call Stack:    (Signature = nsToolkit::GetSharedGC() d1339493) 
     
  nsToolkit::GetSharedGC() 
                                           
     
  nsWidget::GetNativeData() 
                                           
     
  nsWindow::GetNativeData() 
                                           
     
  nsRenderingContextGTK::Init() 
                                           
     
  nsBaseWidget::GetRenderingContext() 
                                           
     
  nsWindow::DoPaint() 
                                           
     
  nsWindow::Update() 
                                           
     
  nsWindow::UpdateIdle() 
                                           
     
  libglib-1.2.so.0 + 0x10ba9 (0x40625ba9) 
                                           
     
  libglib-1.2.so.0 + 0xfbe6 (0x40624be6) 
                                           
     
  libglib-1.2.so.0 + 0x101a1 (0x406251a1) 
                                           
     
  libglib-1.2.so.0 + 0x10341 (0x40625341) 
                                           
     
  libgtk-1.2.so.0 + 0x8c209 (0x4054c209) 
                                           
     
  nsAppShell::Run() 
                                           
     
  nsAppShellService::Run() 
                                           
     
  main1() 
                                           
     
  main() 
                                           
     
  libc.so.6 + 0x181eb (0x4030b1eb)
(Reporter)

Comment 1

19 years ago
btw, i don't see this happening in the tip (linux, 2000.03.21.09)... should this
be relnoted? not sure how common a problem this'd be...
Keywords: beta1, crash, pp
Target Milestone: ---

Comment 2

19 years ago
Kevin, Linux specific in the widget code it looks like
Assignee: troy → kmcclusk

Comment 3

19 years ago
I verified this is not crashing on NT (with today's beta1 branch)
(Assignee)

Comment 4

19 years ago
This bug sounds similar to an old WIN32 bug where paint events came through the 
message queue for a destroyed widget.
Whiteboard: Pavlov and Waqar are looking at the problem.
(Assignee)

Comment 5

19 years ago
Waqar pulled the branch last night and it does not crash for him.

Comment 6

19 years ago
I don't see a crash here either.
(Reporter)

Comment 7

19 years ago
well, heck. i cannot repro this with today's branch bits (2000.03.22.06-nb1b).
go figure. marking wfm. if anyone else sees this, do reopen...
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 8

19 years ago
Marking verified fixed per last comments.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.